1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit go-module systemd
8 DESCRIPTION
="Xray, Penetrates Everything. Also the best v2ray-core, with XTLS support."
9 HOMEPAGE
="https://xtls.github.io/ https://github.com/XTLS/Xray-core"
10 SRC_URI
="https://github.com/XTLS/Xray-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
11 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz"
13 S
="${WORKDIR}/${PN}-core-${PV}"
17 KEYWORDS
="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
19 DEPEND
="app-alternatives/v2ray-geoip
20 app-alternatives/v2ray-geosite"
22 BDEPEND
=">=dev-lang/go-1.21.4"
25 ego build
-o xray
-trimpath -ldflags "-w -s -X 'github.com/XTLS/Xray-core/core.build=${PV}'" .
/main
30 newinitd
"${FILESDIR}/xray.initd" xray
31 systemd_dounit
"${FILESDIR}/xray.service"
32 systemd_newunit
"${FILESDIR}/xray_at.service" xray@.service
33 dosym
-r /usr
/share
/v2ray
/geosite.dat
/usr
/share
/xray
/geosite.dat
34 dosym
-r /usr
/share
/v2ray
/geoip.dat
/usr
/share
/xray
/geoip.dat