app-shells/zfe: add nvchecker
[gentoo-zh.git] / net-proxy / Xray / Xray-24.12.18.ebuild
blob0978f3b24398bb64a0533345780baf908fa1542d
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit go-module systemd
8 DESCRIPTION="Xray, Penetrates Everything. Also the best v2ray-core, with XTLS support."
9 HOMEPAGE="https://xtls.github.io/ https://github.com/XTLS/Xray-core"
10 SRC_URI="https://github.com/XTLS/Xray-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
11 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz"
13 S="${WORKDIR}/${PN}-core-${PV}"
15 LICENSE="MPL-2.0"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
19 DEPEND="app-alternatives/v2ray-geoip
20 app-alternatives/v2ray-geosite"
21 RDEPEND="${DEPEND}"
22 BDEPEND=">=dev-lang/go-1.21.4"
24 src_compile() {
25 ego build -o xray -trimpath -ldflags "-w -s -X 'github.com/XTLS/Xray-core/core.build=${PV}'" ./main
28 src_install() {
29 dobin xray
30 newinitd "${FILESDIR}/xray.initd" xray
31 systemd_dounit "${FILESDIR}/xray.service"
32 systemd_newunit "${FILESDIR}/xray_at.service" xray@.service
33 dosym -r /usr/share/v2ray/geosite.dat /usr/share/xray/geosite.dat
34 dosym -r /usr/share/v2ray/geoip.dat /usr/share/xray/geoip.dat
35 keepdir /etc/xray