app-shells/zfe: add nvchecker
[gentoo-zh.git] / net-proxy / yacd-meta / yacd-meta-0.3.7.ebuild
blob6651f17f0fab34de9ec48e379a655d8e5c1f6941
1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 _MY_PN="Yacd-meta"
8 DESCRIPTION="Yet Another Clash Dashboard"
9 HOMEPAGE="https://github.com/MetaCubeX/Yacd-meta"
10 SRC_URI="
11 https://github.com/MetaCubeX/Yacd-meta/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
12 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-node_modules.tar.xz
15 S="${WORKDIR}/${_MY_PN}-${PV}"
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64"
20 BDEPEND="net-libs/nodejs[npm]"
22 src_unpack() {
23 default
24 mv node_modules "${_MY_PN}-${PV}" || die
27 src_compile() {
28 npm run build || die
31 src_install() {
32 insinto /usr/share/"${PN}"
33 doins -r public/*