1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 # see examples at sci-chemistry/gromacs/gromacs's ebuild files
7 CMAKE_MAKEFILE_GENERATOR
="ninja"
9 inherit cmake unpacker xdg
11 DESCRIPTION
="lightweight and efficient, socks5/http forward proxy"
12 HOMEPAGE
="https://github.com/Chilledheart/yass"
13 SRC_URI
="https://github.com/Chilledheart/yass/releases/download/${PV}/${PN}-${PV}.tar.zst"
14 S
="${WORKDIR}/${PN}-${PV}"
17 #KEYWORDS="amd64 ~arm ~arm64 ~loong ~mips ~riscv ~x86"
18 #FIXME pkgcheck cries on NonsolvableDepsInDev on mips, no idea why
19 KEYWORDS
="amd64 ~arm ~arm64 ~loong ~riscv ~x86"
21 IUSE
="+cli server test cet gui gtk3 gtk4 qt5 qt6 wayland +tcmalloc mimalloc"
23 # tested with FEATURES="-network-sandbox test"
24 # tested with FEATURES="network-sandbox test"
25 # tested with FEATURES="test"
26 RESTRICT
="!test? ( test )"
29 cet? ( ^^ ( amd64 x86 ) )
30 gui? ( || ( gtk3 gtk4 qt5 qt6 ) )
31 tcmalloc? ( !mimalloc )
35 app-misc/ca-certificates
44 tcmalloc? ( dev-util/google-perftools )
45 mimalloc? ( dev-libs/mimalloc )
49 x11-libs/gtk+:3[wayland?]
53 gui-libs/gtk:4[wayland?]
59 wayland? ( dev-qt/qtwayland:5 )
62 dev-qt/qtbase:6=[dbus,gui,widgets,wayland?]
63 wayland? ( dev-qt/qtwayland:6 )
71 >=dev-build/cmake-3.13.4
72 app-alternatives/ninja
82 test? ( net-misc/curl )
87 # some tests require network access, comment it out if not supported
88 if has network-sandbox
${FEATURES}; then
89 sed -i -e 's/BUILD_TESTS_NO_NETWORK/BUILD_TESTS/g' "${S}/CMakeLists.txt"
95 -DCMAKE_INSTALL_SYSCONFDIR=/etc
96 -DBUILD_SHARED_LIBS=off
99 -DSERVER=$
(usex server
)
100 -DUSE_CET=$
(usex cet
)
101 -DBUILD_TESTS=$
(usex
test)
102 -DUSE_TCMALLOC=$
(usex tcmalloc
)
103 -DUSE_SYSTEM_TCMALLOC=$
(usex tcmalloc
)
104 -DUSE_MIMALLOC=$
(usex mimalloc
)
105 -DUSE_SYSTEM_MIMALLOC=$
(usex mimalloc
)
106 -DUSE_SYSTEM_MBEDTLS=on
110 -DUSE_SYSTEM_CARES=on
111 -DUSE_SYSTEM_NGHTTP2=on
113 -DUSE_SYSTEM_JSONCPP=on
117 mycmakeargs
+=( -DGUI=ON
-DUSE_QT6=ON
)
119 mycmakeargs
+=( -DGUI=ON
-DUSE_QT5=ON
)
121 mycmakeargs
+=( -DGUI=ON
-DUSE_GTK4=ON
)
123 mycmakeargs
+=( -DGUI=ON
-DUSE_GTK4=OFF
)
125 mycmakeargs
+=( -DGUI=OFF
)