1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION
="Linux kernel driver for reading sensors of AMD Zen family CPUs"
9 HOMEPAGE
="https://git.exozy.me/a/zenpower3"
11 if [[ ${PV} == 9999 ]] ; then
12 EGIT_REPO_URI
="https://git.exozy.me/a/zenpower3.git"
14 unset MODULES_KERNEL_MAX
16 SRC_URI
="https://git.exozy.me/a/zenpower3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
24 CONFIG_CHECK
="HWMON PCI AMD_NB"
25 MODULES_KERNEL_MIN
=5.3.4
31 local modargs
=( TARGET
="${KV_FULL}" KERNEL_BUILD
="${KV_OUT_DIR}" )
32 linux-mod-r1_src_compile
36 linux-mod-r1_pkg_postinst
39 elog
"To use zenpower, please disable k10temp first"
40 elog
"see https://git.exozy.me/a/zenpower3#module-activation"