app-shells/zfe: add nvchecker
[gentoo-zh.git] / www-servers / miniserve / miniserve-0.28.0.ebuild
blob681d0fc4709d862141bf8bf4aff9b83461489e51
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.3
6 EAPI=8
8 CRATES="
9 actix-codec@0.5.2
10 actix-files@0.6.6
11 actix-http@3.9.0
12 actix-macros@0.2.4
13 actix-multipart-derive@0.7.0
14 actix-multipart@0.7.2
15 actix-router@0.5.3
16 actix-rt@2.10.0
17 actix-server@2.5.0
18 actix-service@2.0.2
19 actix-tls@3.4.0
20 actix-utils@3.0.1
21 actix-web-codegen@4.3.0
22 actix-web-httpauth@0.8.2
23 actix-web@4.9.0
24 addr2line@0.24.1
25 adler2@2.0.0
26 adler32@1.2.0
27 ahash@0.8.11
28 aho-corasick@1.1.3
29 alloc-no-stdlib@2.0.4
30 alloc-stdlib@0.2.2
31 allocator-api2@0.2.18
32 alphanumeric-sort@1.5.3
33 android-tzdata@0.1.1
34 android_system_properties@0.1.5
35 anstream@0.6.15
36 anstyle-parse@0.2.5
37 anstyle-query@1.1.1
38 anstyle-wincon@3.0.4
39 anstyle@1.0.8
40 anyhow@1.0.88
41 arbitrary@1.3.2
42 assert_cmd@2.0.16
43 assert_fs@1.1.2
44 autocfg@1.3.0
45 backtrace@0.3.74
46 base64@0.22.1
47 bit-set@0.5.3
48 bit-vec@0.6.3
49 bitflags@2.6.0
50 block-buffer@0.10.4
51 brotli-decompressor@4.0.1
52 brotli@6.0.0
53 bstr@1.10.0
54 bumpalo@3.16.0
55 byteorder@1.5.0
56 bytes@1.7.1
57 bytesize@1.3.0
58 bytestring@1.3.1
59 caseless@0.2.1
60 cc@1.1.18
61 cfg-if@1.0.0
62 chrono-humanize@0.2.3
63 chrono@0.4.38
64 clap@4.5.17
65 clap_builder@4.5.17
66 clap_complete@4.5.26
67 clap_derive@4.5.13
68 clap_lex@0.7.2
69 clap_mangen@0.2.23
70 codemap@0.1.3
71 colorchoice@1.0.2
72 colored@2.1.0
73 comrak@0.28.0
74 convert_case@0.4.0
75 core-foundation-sys@0.8.7
76 core2@0.4.0
77 cpufeatures@0.2.14
78 crc32fast@1.4.2
79 crossbeam-deque@0.8.5
80 crossbeam-epoch@0.9.18
81 crossbeam-utils@0.8.20
82 crypto-common@0.1.6
83 darling@0.20.10
84 darling_core@0.20.10
85 darling_macro@0.20.10
86 dary_heap@0.3.6
87 deranged@0.3.11
88 derive_arbitrary@1.3.2
89 derive_builder@0.20.1
90 derive_builder_core@0.20.1
91 derive_builder_macro@0.20.1
92 derive_more@0.99.18
93 deunicode@1.6.0
94 diff@0.1.13
95 difflib@0.4.0
96 digest@0.10.7
97 displaydoc@0.2.5
98 doc-comment@0.3.3
99 encoding_rs@0.8.34
100 entities@1.0.1
101 equivalent@1.0.1
102 errno@0.3.9
103 fake-tty@0.3.1
104 fast_qr@0.12.5
105 fastrand@2.1.1
106 filetime@0.2.25
107 flate2@1.0.33
108 float-cmp@0.9.0
109 fnv@1.0.7
110 form_urlencoded@1.2.1
111 futf@0.1.5
112 futures-channel@0.3.30
113 futures-core@0.3.30
114 futures-executor@0.3.30
115 futures-io@0.3.30
116 futures-macro@0.3.30
117 futures-sink@0.3.30
118 futures-task@0.3.30
119 futures-timer@3.0.3
120 futures-util@0.3.30
121 futures@0.3.30
122 generic-array@0.14.7
123 getrandom@0.2.15
124 gimli@0.31.0
125 glob@0.3.1
126 globset@0.4.15
127 globwalk@0.9.1
128 grass@0.13.4
129 grass_compiler@0.13.4
130 h2@0.3.26
131 hashbrown@0.14.5
132 heck@0.5.0
133 hermit-abi@0.3.9
134 hex@0.4.3
135 html5ever@0.26.0
136 http-body-util@0.1.2
137 http-body@1.0.1
138 http-range@0.1.5
139 http@0.2.12
140 http@1.1.0
141 httparse@1.9.4
142 httpdate@1.0.3
143 hyper-rustls@0.27.3
144 hyper-util@0.1.8
145 hyper@1.4.1
146 iana-time-zone-haiku@0.1.2
147 iana-time-zone@0.1.60
148 ident_case@1.0.1
149 idna@0.5.0
150 if-addrs@0.13.3
151 ignore@0.4.23
152 impl-more@0.1.6
153 include_sass@0.13.4
154 indexmap@2.5.0
155 ipnet@2.10.0
156 is_terminal_polyfill@1.70.1
157 itoa@1.0.11
158 jobserver@0.1.32
159 js-sys@0.3.70
160 language-tags@0.3.2
161 lasso@0.7.3
162 lazy_static@1.5.0
163 libc@0.2.158
164 libflate@2.1.0
165 libflate_lz77@2.1.0
166 libredox@0.1.3
167 linux-raw-sys@0.4.14
168 local-channel@0.1.5
169 local-waker@0.1.4
170 lock_api@0.4.12
171 log@0.4.22
172 mac@0.1.1
173 markup5ever@0.11.0
174 markup5ever_rcdom@0.2.0
175 maud@0.26.0
176 maud_macros@0.26.0
177 memchr@2.7.4
178 mime@0.3.17
179 mime_guess@2.0.5
180 miniz_oxide@0.8.0
181 mio@1.0.2
182 nanoid@0.4.0
183 new_debug_unreachable@1.0.6
184 normalize-line-endings@0.3.0
185 num-conv@0.1.0
186 num-traits@0.2.19
187 num_threads@0.1.7
188 object@0.36.4
189 once_cell@1.19.0
190 parking_lot@0.12.3
191 parking_lot_core@0.9.10
192 parse-size@1.0.0
193 paste@1.0.15
194 percent-encoding@2.3.1
195 phf@0.10.1
196 phf@0.11.2
197 phf_codegen@0.10.0
198 phf_generator@0.10.0
199 phf_generator@0.11.2
200 phf_macros@0.11.2
201 phf_shared@0.10.0
202 phf_shared@0.11.2
203 pin-project-internal@1.1.5
204 pin-project-lite@0.2.14
205 pin-project@1.1.5
206 pin-utils@0.1.0
207 pkg-config@0.3.30
208 port_check@0.2.1
209 powerfmt@0.2.0
210 ppv-lite86@0.2.20
211 precomputed-hash@0.1.1
212 predicates-core@1.0.8
213 predicates-tree@1.0.11
214 predicates@3.1.2
215 pretty_assertions@1.4.0
216 proc-macro-crate@3.2.0
217 proc-macro-error-attr@1.0.4
218 proc-macro-error@1.0.4
219 proc-macro2@1.0.86
220 quinn-proto@0.11.8
221 quinn-udp@0.5.5
222 quinn@0.11.5
223 quote@1.0.37
224 rand@0.8.5
225 rand_chacha@0.3.1
226 rand_core@0.6.4
227 redox_syscall@0.5.4
228 regex-automata@0.4.7
229 regex-lite@0.1.6
230 regex-syntax@0.8.4
231 regex@1.10.6
232 relative-path@1.9.3
233 reqwest@0.12.7
234 ring@0.17.8
235 rle-decode-fast@1.0.3
236 roff@0.2.2
237 rstest@0.22.0
238 rstest_macros@0.22.0
239 rustc-demangle@0.1.24
240 rustc-hash@2.0.0
241 rustc_version@0.4.1
242 rustix@0.38.37
243 rustls-pemfile@2.1.3
244 rustls-pki-types@1.8.0
245 rustls-webpki@0.102.8
246 rustls@0.23.13
247 rustversion@1.0.17
248 ryu@1.0.18
249 same-file@1.0.6
250 scopeguard@1.2.0
251 select@0.6.0
252 semver@1.0.23
253 serde@1.0.210
254 serde_derive@1.0.210
255 serde_json@1.0.128
256 serde_plain@1.0.2
257 serde_urlencoded@0.7.1
258 sha1@0.10.6
259 sha2@0.10.8
260 shlex@1.3.0
261 signal-hook-registry@1.4.2
262 simplelog@0.12.2
263 siphasher@0.3.11
264 slab@0.4.9
265 slug@0.1.6
266 smallvec@1.13.2
267 socket2@0.5.7
268 spin@0.9.8
269 string_cache@0.8.7
270 string_cache_codegen@0.5.2
271 strsim@0.11.1
272 strum@0.26.3
273 strum_macros@0.26.4
274 subtle@2.6.1
275 syn@1.0.109
276 syn@2.0.77
277 sync_wrapper@1.0.1
278 tar@0.4.41
279 tempfile@3.12.0
280 tendril@0.4.3
281 termcolor@1.4.1
282 terminal_size@0.3.0
283 termtree@0.4.1
284 thiserror-impl@1.0.63
285 thiserror@1.0.63
286 time-core@0.1.2
287 time-macros@0.2.18
288 time@0.3.36
289 tinyvec@1.8.0
290 tinyvec_macros@0.1.1
291 tokio-rustls@0.26.0
292 tokio-util@0.7.12
293 tokio@1.40.0
294 toml_datetime@0.6.8
295 toml_edit@0.22.20
296 tower-layer@0.3.3
297 tower-service@0.3.3
298 tower@0.4.13
299 tracing-core@0.1.32
300 tracing@0.1.40
301 try-lock@0.2.5
302 typed-arena@2.0.2
303 typenum@1.17.0
304 unicase@2.7.0
305 unicode-bidi@0.3.15
306 unicode-ident@1.0.13
307 unicode-normalization@0.1.23
308 unicode_categories@0.1.1
309 untrusted@0.9.0
310 url@2.5.2
311 utf-8@0.7.6
312 utf8parse@0.2.2
313 v_htmlescape@0.15.8
314 version_check@0.9.5
315 wait-timeout@0.2.0
316 walkdir@2.5.0
317 want@0.3.1
318 wasi@0.11.0+wasi-snapshot-preview1
319 wasm-bindgen-backend@0.2.93
320 wasm-bindgen-futures@0.4.43
321 wasm-bindgen-macro-support@0.2.93
322 wasm-bindgen-macro@0.2.93
323 wasm-bindgen-shared@0.2.93
324 wasm-bindgen@0.2.93
325 web-sys@0.3.70
326 webpki-roots@0.26.5
327 winapi-util@0.1.9
328 windows-core@0.52.0
329 windows-registry@0.2.0
330 windows-result@0.2.0
331 windows-strings@0.1.0
332 windows-sys@0.48.0
333 windows-sys@0.52.0
334 windows-sys@0.59.0
335 windows-targets@0.48.5
336 windows-targets@0.52.6
337 windows_aarch64_gnullvm@0.48.5
338 windows_aarch64_gnullvm@0.52.6
339 windows_aarch64_msvc@0.48.5
340 windows_aarch64_msvc@0.52.6
341 windows_i686_gnu@0.48.5
342 windows_i686_gnu@0.52.6
343 windows_i686_gnullvm@0.52.6
344 windows_i686_msvc@0.48.5
345 windows_i686_msvc@0.52.6
346 windows_x86_64_gnu@0.48.5
347 windows_x86_64_gnu@0.52.6
348 windows_x86_64_gnullvm@0.48.5
349 windows_x86_64_gnullvm@0.52.6
350 windows_x86_64_msvc@0.48.5
351 windows_x86_64_msvc@0.52.6
352 winnow@0.6.18
353 xattr@1.3.1
354 xml5ever@0.17.0
355 yansi@0.5.1
356 zerocopy-derive@0.7.35
357 zerocopy@0.7.35
358 zeroize@1.8.1
359 zip@2.2.0
360 zstd-safe@7.2.1
361 zstd-sys@2.0.13+zstd.1.5.6
362 zstd@0.13.2
365 inherit cargo
367 DESCRIPTION="For when you really just want to serve some files over HTTP right now!"
368 HOMEPAGE="https://github.com/svenstaro/miniserve"
369 SRC_URI="
370 https://github.com/svenstaro/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
371 ${CARGO_CRATE_URIS}
374 LICENSE="MIT"
375 # Dependent crate licenses
376 LICENSE+=" Apache-2.0 BSD-2 BSD ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB"
377 SLOT="0"
378 KEYWORDS="~amd64"