1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DESCRIPTION
="workaround to always show mouse cursor under x11"
7 HOMEPAGE
="https://aur.archlinux.org/packages/extramaus"
8 SRC_URI
="https://gist.githubusercontent.com/ibLeDy/aecab4b95b242ff07108c6d58e35d421/raw/44f2188279b4aec54f0d667bda72e542829c3240/extramaus.c"
10 inherit toolchain-funcs
14 #https://gist.github.com/ibLeDy/aecab4b95b242ff07108c6d58e35d421#file-extramaus-c-L18-L36
16 DEPEND
="x11-libs/libX11
24 cp "${DISTDIR}/extramaus.c" "${S}/"
29 $CC ${CFLAGS} ${LDFLAGS} extramaus.c
-o extramaus
-lX11 -lXext