x11-terms/ghostty: add missing depend dev-libs/oniguruma
[gentoo-zh.git] / x11-misc / flatpak-xdg-utils / flatpak-xdg-utils-1.0.6.ebuild
blob8193bf3c9fd771154fb457f9ab53b5bfdb3c80fa
1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit meson
8 DESCRIPTION="Utilities for containerized apps to launch programs outside the container"
9 HOMEPAGE="https://github.com/flatpak/flatpak-xdg-utils"
10 SRC_URI="https://github.com/flatpak/flatpak-xdg-utils/releases/download/${PV}/flatpak-xdg-utils-${PV}.tar.xz"
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 RDEPEND="dev-libs/glib:2"
15 DEPEND="${RDEPEND}"
16 BDEPEND="${RDEPEND}"
17 KEYWORDS="~amd64 ~arm64 ~loong"
19 src_configure() {
20 meson_src_configure --bindir=/usr/lib/"${PN}"
23 src_install() {
24 meson_src_install
25 dosym -r /usr/lib/"${PN}"/flatpak-spawn /usr/bin/flatpak-spawn