sys-apps/isd: new package
[gentoo-zh.git] / x11-misc / picom-jonaburg / picom-jonaburg-9999.ebuild
blob1271bef4c61ed8832d311b5c38dee282aab6638c
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit git-r3 meson xdg
8 DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
9 HOMEPAGE="https://github.com/jonaburg/picom"
10 EGIT_REPO_URI="https://github.com/jonaburg/picom.git"
12 LICENSE="MPL-2.0 MIT"
13 SLOT="0"
14 IUSE="+config-file dbus +doc +drm opengl pcre"
16 RDEPEND="dev-libs/libev
17         dev-libs/uthash
18         x11-libs/libX11
19         x11-libs/libxcb
20         x11-libs/libXext
21         x11-libs/pixman
22         x11-libs/xcb-util-image
23         x11-libs/xcb-util-renderutil
24         config-file? (
25                 dev-libs/libconfig:=
26                 dev-libs/libxdg-basedir
27         )
28         dbus? ( sys-apps/dbus )
29         drm? ( x11-libs/libdrm )
30         opengl? ( virtual/opengl )
31         pcre? ( dev-libs/libpcre )
32         !x11-misc/compton
33         !x11-misc/picom"
34 DEPEND="${RDEPEND}
35         x11-base/xorg-proto"
36 BDEPEND="virtual/pkgconfig
37         doc? ( app-text/asciidoc )"
39 DOCS=( README.md picom.sample.conf )
41 src_configure() {
42         local emesonargs=(
43                 $(meson_use config-file config_file)
44                 $(meson_use dbus)
45                 $(meson_use doc with_docs)
46                 $(meson_use opengl)
47                 $(meson_use pcre regex)
48         )
50         meson_src_configure