1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 PYTHON_COMPAT=( python3_{9..11} )
7 inherit python-single-r1 unpacker
9 DESCRIPTION="Deepin Wine Helper"
10 HOMEPAGE="https://www.deepin.org"
12 COMMON_URI="https://home-store-packages.uniontech.com/appstore/pool/appstore/d"
13 SRC_URI="${COMMON_URI}/${PN}/${PN}_${PV}-${PR/r/}_i386.deb"
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
23 app-emulation/deepin-wine-plugin[virtual-pkg]
29 QA_PREBUILT="opt/deepinwine/*"
30 QA_FLAGS_IGNORED="opt/deepinwine/*"
33 python_fix_shebang -f "opt/deepinwine/tools/add_hotkeys"
34 python_fix_shebang -f "opt/deepinwine/tools/get_tray_window"
38 fperms 755 -R /opt/deepinwine/tools/