net-misc/hoppscotch-bin: bump version to 24.12.0.0
[gentoo-zh.git] / media-sound / yesplaymusic-bin / yesplaymusic-bin-0.4.8.ebuild
blob6edba1c1a5961797019137169331884430648603
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop xdg
8 DESCRIPTION="A third party music player for Netease Music"
9 HOMEPAGE="https://github.com/qier222/YesPlayMusic"
10 BASE_URI="https://github.com/qier222/YesPlayMusic/releases/download/v${PV}-2"
11 SRC_URI="${BASE_URI}/${PN%-bin}-${PV}.pacman"
13 S="${WORKDIR}"
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64"
19 RESTRICT="mirror strip"
21 QA_PRESTRIPPED="*"
23 RDEPEND="
24         app-arch/gzip
25         dev-libs/nss
26         media-libs/alsa-lib
27         net-print/cups
28         x11-libs/gtk+:*
29         x11-libs/libxkbcommon"
31 QA_PREBUILT="
32         opt/YesPlayMusic/chrome-sandbox
33         opt/YesPlayMusic/libEGL.so
34         opt/YesPlayMusic/libGLESv2.so
35         opt/YesPlayMusic/libffmpeg.so
36         opt/YesPlayMusic/libvk_swiftshader.so
37         opt/YesPlayMusic/libvulkan.so.1
38         opt/YesPlayMusic/swiftshader/libEGL.so
39         opt/YesPlayMusic/swiftshader/libGLESv2.so
40         opt/YesPlayMusic/yesplaymusic
43 src_unpack(){
44         tar xf "${DISTDIR}/yesplaymusic-${PV}.pacman" || die
47 src_install(){
48         insinto "/opt"
49         doins -r "${S}/opt/YesPlayMusic"
50         for si in 16 24 32 48 64 128 256 512; do
51                 doicon -s ${si} usr/share/icons/hicolor/${si}x${si}/apps/${PN%-bin}.png
52         done
53         domenu "${FILESDIR}/${PN%-bin}.desktop"
54         fperms 0755 "/opt/YesPlayMusic/yesplaymusic"