1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.4
52 bytecheck_derive@0.6.12
67 concurrent-queue@2.5.0
72 core-foundation-sys@0.8.7
73 core-foundation@0.10.0
75 core-graphics-types@0.2.0
79 crossbeam-channel@0.5.13
80 crossbeam-utils@0.8.20
90 derive_is_enum_variant@0.1.1
98 document-features@0.2.10
99 documented-macros@0.9.1
110 enumflags2_derive@0.7.10
113 event-listener-strategy@0.5.2
120 foreign-types-macros@0.2.3
121 foreign-types-shared@0.1.1
122 foreign-types-shared@0.3.1
125 form_urlencoded@1.2.1
127 from_variants_impl@1.0.2
129 futures-channel@0.3.31
131 futures-executor@0.3.31
138 gdk-pixbuf-sys@0.18.0
139 gdk-pixbuf-sys@0.20.4
193 icu_collections@1.5.0
195 icu_locid_transform@1.5.0
196 icu_locid_transform_data@1.5.0
198 icu_normalizer_data@1.5.0
200 icu_properties_data@1.5.0
202 icu_provider_macros@1.5.0
216 libappindicator-sys@0.9.0
217 libappindicator@0.9.0
223 libmimalloc-sys@0.1.39
242 minimal-lexical@0.2.1
257 objc-foundation@0.1.1
260 objc2-core-data@0.2.2
261 objc2-core-image@0.2.2
263 objc2-foundation@0.2.2
265 objc2-quartz-core@0.2.2
286 parking_lot_core@0.9.10
288 percent-encoding@2.3.1
293 pin-project-lite@0.2.15
304 proc-macro-crate@1.3.1
305 proc-macro-crate@2.0.0
306 proc-macro-crate@3.2.0
307 proc-macro-error-attr@1.0.4
308 proc-macro-error@1.0.4
312 ptr_meta_derive@0.1.4
322 raw-window-handle@0.6.2
325 regex-automata@0.1.10
338 rust_decimal_macros@1.36.0
339 rustc-demangle@0.1.24
343 rustls-pki-types@1.10.0
344 rustls-webpki@0.102.8
352 security-framework-sys@2.12.1
353 security-framework@2.11.1
360 serde_urlencoded@0.7.1
364 signal-hook-registry@1.4.2
375 stable_deref_trait@1.2.0
376 static_assertions@1.1.0
389 system-configuration-sys@0.6.0
390 system-configuration@0.6.1
394 target-lexicon@0.12.16
398 thiserror-impl@1.0.69
410 tokio-native-tls@0.3.1
420 tracing-attributes@0.1.27
422 tracing-journald@0.3.0
424 tracing-subscriber@0.3.18
432 unicode-normalization@0.1.24
433 unicode-segmentation@1.12.0
445 version-compare@0.2.0
450 wasi@0.11.0+wasi-snapshot-preview1
451 wasm-bindgen-backend@0.2.95
452 wasm-bindgen-futures@0.4.45
453 wasm-bindgen-macro-support@0.2.95
454 wasm-bindgen-macro@0.2.95
455 wasm-bindgen-shared@0.2.95
457 wayland-backend@0.3.7
458 wayland-client@0.31.7
459 wayland-protocols@0.32.5
460 wayland-scanner@0.31.5
463 winapi-i686-pc-windows-gnu@0.4.0
464 winapi-x86_64-pc-windows-gnu@0.4.0
467 windows-implement@0.58.0
468 windows-interface@0.58.0
469 windows-registry@0.2.0
471 windows-strings@0.1.0
475 windows-targets@0.48.5
476 windows-targets@0.52.6
478 windows_aarch64_gnullvm@0.48.5
479 windows_aarch64_gnullvm@0.52.6
480 windows_aarch64_msvc@0.48.5
481 windows_aarch64_msvc@0.52.6
482 windows_exe_info@0.4.2
483 windows_i686_gnu@0.48.5
484 windows_i686_gnu@0.52.6
485 windows_i686_gnullvm@0.52.6
486 windows_i686_msvc@0.48.5
487 windows_i686_msvc@0.52.6
488 windows_x86_64_gnu@0.48.5
489 windows_x86_64_gnu@0.52.6
490 windows_x86_64_gnullvm@0.48.5
491 windows_x86_64_gnullvm@0.52.6
492 windows_x86_64_msvc@0.48.5
493 windows_x86_64_msvc@0.52.6
508 zerocopy-derive@0.7.35
510 zerofrom-derive@0.1.4
513 zerovec-derive@0.10.3
516 zvariant_derive@4.2.0
520 PLOCALES="en_US it_IT zh_CN"
521 PLOCALE_BACKUP="en_US"
523 inherit cargo desktop gnome2-utils plocale xdg
525 DESCRIPTION="Simple On Screen lyrics Display for linux/unix"
527 https://waylyrics.github.io/waylyrics/waylyrics
528 https://github.com/waylyrics/waylyrics
531 if [[ "${PV}" == *9999* ]]; then
533 EGIT_REPO_URI="https://github.com/waylyrics/waylyrics.git"
536 https://github.com/waylyrics/waylyrics/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
539 KEYWORDS="~amd64 ~loong"
542 LICENSE="MIT CC-BY-4.0"
543 # Dependent crate licenses
545 Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD GPL-3+ ISC MIT
546 MPL-2.0 Unicode-DFS-2016 Unlicense
562 sys-apps/xdg-desktop-portal
566 export WAYLYRICS_THEME_PRESETS_DIR="/usr/share/${PN}/themes"
567 cargo_src_compile --all-targets --all-features
573 doicon -s scalable "${S}/res/icons/hicolor/scalable/apps/io.github.waylyrics.Waylyrics.svg"
574 domenu "${S}/metainfo/io.github.waylyrics.Waylyrics.desktop"
576 insinto "/usr/share/glib-2.0/schemas"
577 doins "${S}/metainfo/io.github.waylyrics.Waylyrics.gschema.xml"
579 insinto "/usr/share/metainfo"
580 doins "${S}/metainfo/io.github.waylyrics.Waylyrics.metainfo.xml"
582 insinto "/usr/share/${PN}"
585 cd "${S}/locales" || die
587 if [[ -f ${1}/LC_MESSAGES/waylyrics.po ]]; then
588 local file=${1}/LC_MESSAGES/waylyrics.po
589 msgfmt "${file}" -o "${file%.po}.mo" || die
590 insinto /usr/share/locale/${1}/LC_MESSAGES
591 doins "${file%.po}.mo"
594 plocale_for_each_locale install_locale
598 gnome2_schemas_update
603 gnome2_schemas_update