app-text/goldendict: add 24.09.1
[gentoo-zh.git] / app-admin / rbw / rbw-1.12.1.ebuild
blobea31376554b4bea467046f57e691d578d4ac3eb7
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.3
6 EAPI=8
8 CRATES="
9         addr2line@0.22.0
10         adler@1.0.2
11         aes@0.8.4
12         aho-corasick@1.1.3
13         anstream@0.6.15
14         anstyle-parse@0.2.5
15         anstyle-query@1.1.1
16         anstyle-wincon@3.0.4
17         anstyle@1.0.8
18         anyhow@1.0.86
19         argon2@0.5.3
20         arrayvec@0.7.4
21         async-trait@0.1.81
22         autocfg@1.3.0
23         axum-core@0.4.3
24         axum@0.7.5
25         backtrace@0.3.73
26         base32@0.5.1
27         base64@0.22.1
28         base64ct@1.6.0
29         bitflags@1.3.2
30         bitflags@2.6.0
31         blake2@0.10.6
32         block-buffer@0.10.4
33         block-padding@0.3.3
34         block@0.1.6
35         bumpalo@3.16.0
36         byteorder@1.5.0
37         bytes@1.6.1
38         calloop-wayland-source@0.3.0
39         calloop@0.13.0
40         cbc@0.1.2
41         cc@1.1.6
42         cfg-if@1.0.0
43         cipher@0.4.4
44         clap@4.5.11
45         clap_builder@4.5.11
46         clap_complete@4.5.11
47         clap_derive@4.5.11
48         clap_lex@0.7.2
49         clipboard-win@3.1.1
50         colorchoice@1.0.2
51         concurrent-queue@2.5.0
52         const-oid@0.9.6
53         copypasta@0.10.1
54         core-foundation-sys@0.8.6
55         core-foundation@0.9.4
56         cpufeatures@0.2.12
57         crossbeam-utils@0.8.20
58         crypto-common@0.1.6
59         cursor-icon@1.1.0
60         daemonize@0.5.0
61         data-encoding@2.6.0
62         der@0.7.9
63         digest@0.10.7
64         directories@5.0.0
65         dirs-sys@0.4.0
66         dlib@0.5.2
67         downcast-rs@1.2.1
68         env_filter@0.1.2
69         env_logger@0.11.5
70         errno@0.3.9
71         fastrand@2.1.0
72         fnv@1.0.7
73         form_urlencoded@1.2.1
74         futures-channel@0.3.30
75         futures-core@0.3.30
76         futures-executor@0.3.30
77         futures-io@0.3.30
78         futures-macro@0.3.30
79         futures-sink@0.3.30
80         futures-task@0.3.30
81         futures-util@0.3.30
82         futures@0.3.30
83         generic-array@0.14.7
84         gethostname@0.4.3
85         getrandom@0.2.15
86         gimli@0.29.0
87         heck@0.5.0
88         hermit-abi@0.3.9
89         hermit-abi@0.4.0
90         hkdf@0.12.4
91         hmac@0.12.1
92         http-body-util@0.1.2
93         http-body@1.0.1
94         http@1.1.0
95         httparse@1.9.4
96         httpdate@1.0.3
97         humantime@2.1.0
98         hyper-rustls@0.27.2
99         hyper-util@0.1.6
100         hyper@1.4.1
101         idna@0.5.0
102         inout@0.1.3
103         ipnet@2.9.0
104         is-docker@0.2.0
105         is-terminal@0.4.12
106         is-wsl@0.4.0
107         is_terminal_polyfill@1.70.1
108         itoa@1.0.11
109         js-sys@0.3.69
110         lazy-bytes-cast@5.0.1
111         lazy_static@1.5.0
112         libc@0.2.155
113         libloading@0.8.5
114         libm@0.2.8
115         libredox@0.1.3
116         linux-raw-sys@0.4.14
117         lock_api@0.4.12
118         log@0.4.22
119         mach2@0.4.2
120         malloc_buf@0.0.6
121         matchit@0.7.3
122         memchr@2.7.4
123         memmap2@0.9.4
124         mime@0.3.17
125         miniz_oxide@0.7.4
126         mio@1.0.1
127         num-bigint-dig@0.8.4
128         num-integer@0.1.46
129         num-iter@0.1.45
130         num-traits@0.2.19
131         objc-foundation@0.1.1
132         objc@0.2.7
133         objc_id@0.1.1
134         object@0.36.2
135         once_cell@1.19.0
136         open@5.3.0
137         openssl-probe@0.1.5
138         parking_lot@0.12.3
139         parking_lot_core@0.9.10
140         password-hash@0.5.0
141         paste@1.0.15
142         pathdiff@0.2.1
143         pbkdf2@0.12.2
144         pem-rfc7468@0.7.0
145         percent-encoding@2.3.1
146         pin-project-internal@1.1.5
147         pin-project-lite@0.2.14
148         pin-project@1.1.5
149         pin-utils@0.1.0
150         pkcs1@0.7.5
151         pkcs8@0.10.2
152         pkg-config@0.3.30
153         polling@3.7.2
154         ppv-lite86@0.2.17
155         proc-macro2@1.0.86
156         quick-xml@0.34.0
157         quinn-proto@0.11.3
158         quinn-udp@0.5.4
159         quinn@0.11.2
160         quote@1.0.36
161         rand@0.8.5
162         rand_chacha@0.3.1
163         rand_core@0.6.4
164         redox_syscall@0.5.3
165         redox_users@0.4.5
166         regex-automata@0.4.7
167         regex-syntax@0.8.4
168         regex@1.10.5
169         region@3.0.2
170         reqwest@0.12.5
171         ring@0.17.8
172         rmp@0.8.14
173         rmpv@1.3.0
174         rsa@0.9.6
175         rustc-demangle@0.1.24
176         rustc-hash@1.1.0
177         rustix@0.38.34
178         rustls-native-certs@0.7.1
179         rustls-pemfile@2.1.2
180         rustls-pki-types@1.7.0
181         rustls-webpki@0.102.6
182         rustls@0.23.12
183         rustversion@1.0.17
184         ryu@1.0.18
185         schannel@0.1.23
186         scoped-tls@1.0.1
187         scopeguard@1.2.0
188         security-framework-sys@2.11.1
189         security-framework@2.11.1
190         serde@1.0.204
191         serde_derive@1.0.204
192         serde_json@1.0.120
193         serde_path_to_error@0.1.16
194         serde_repr@0.1.19
195         serde_urlencoded@0.7.1
196         sha1@0.10.6
197         sha2@0.10.8
198         signal-hook-registry@1.4.2
199         signature@2.2.0
200         slab@0.4.9
201         smallvec@1.13.2
202         smawk@0.3.2
203         smithay-client-toolkit@0.19.2
204         smithay-clipboard@0.7.2
205         socket2@0.5.7
206         spin@0.9.8
207         spki@0.7.3
208         strsim@0.11.1
209         subtle@2.6.1
210         syn@2.0.72
211         sync_wrapper@0.1.2
212         sync_wrapper@1.0.1
213         tempfile@3.10.1
214         terminal_size@0.3.0
215         textwrap@0.16.1
216         thiserror-impl@1.0.63
217         thiserror@1.0.63
218         tinyvec@1.8.0
219         tinyvec_macros@0.1.1
220         tokio-macros@2.4.0
221         tokio-rustls@0.26.0
222         tokio-stream@0.1.15
223         tokio-tungstenite@0.23.1
224         tokio@1.39.2
225         totp-lite@2.0.1
226         tower-layer@0.3.2
227         tower-service@0.3.2
228         tower@0.4.13
229         tracing-attributes@0.1.27
230         tracing-core@0.1.32
231         tracing@0.1.40
232         try-lock@0.2.5
233         tungstenite@0.23.0
234         typenum@1.17.0
235         unicode-bidi@0.3.15
236         unicode-ident@1.0.12
237         unicode-linebreak@0.1.5
238         unicode-normalization@0.1.23
239         unicode-width@0.1.13
240         untrusted@0.9.0
241         url@2.5.2
242         urlencoding@2.1.3
243         utf-8@0.7.6
244         utf8parse@0.2.2
245         uuid@1.10.0
246         version_check@0.9.5
247         want@0.3.1
248         wasi@0.11.0+wasi-snapshot-preview1
249         wasm-bindgen-backend@0.2.92
250         wasm-bindgen-futures@0.4.42
251         wasm-bindgen-macro-support@0.2.92
252         wasm-bindgen-macro@0.2.92
253         wasm-bindgen-shared@0.2.92
254         wasm-bindgen@0.2.92
255         wayland-backend@0.3.6
256         wayland-client@0.31.5
257         wayland-csd-frame@0.3.0
258         wayland-cursor@0.31.5
259         wayland-protocols-wlr@0.3.3
260         wayland-protocols@0.32.3
261         wayland-scanner@0.31.4
262         wayland-sys@0.31.4
263         web-sys@0.3.69
264         winapi-i686-pc-windows-gnu@0.4.0
265         winapi-x86_64-pc-windows-gnu@0.4.0
266         winapi@0.3.9
267         windows-sys@0.45.0
268         windows-sys@0.48.0
269         windows-sys@0.52.0
270         windows-targets@0.42.2
271         windows-targets@0.48.5
272         windows-targets@0.52.6
273         windows_aarch64_gnullvm@0.42.2
274         windows_aarch64_gnullvm@0.48.5
275         windows_aarch64_gnullvm@0.52.6
276         windows_aarch64_msvc@0.42.2
277         windows_aarch64_msvc@0.48.5
278         windows_aarch64_msvc@0.52.6
279         windows_i686_gnu@0.42.2
280         windows_i686_gnu@0.48.5
281         windows_i686_gnu@0.52.6
282         windows_i686_gnullvm@0.52.6
283         windows_i686_msvc@0.42.2
284         windows_i686_msvc@0.48.5
285         windows_i686_msvc@0.52.6
286         windows_x86_64_gnu@0.42.2
287         windows_x86_64_gnu@0.48.5
288         windows_x86_64_gnu@0.52.6
289         windows_x86_64_gnullvm@0.42.2
290         windows_x86_64_gnullvm@0.48.5
291         windows_x86_64_gnullvm@0.52.6
292         windows_x86_64_msvc@0.42.2
293         windows_x86_64_msvc@0.48.5
294         windows_x86_64_msvc@0.52.6
295         winreg@0.52.0
296         x11-clipboard@0.9.2
297         x11rb-protocol@0.13.1
298         x11rb@0.13.1
299         xcursor@0.3.6
300         xkeysym@0.2.1
301         zeroize@1.8.1
304 inherit cargo shell-completion
306 DESCRIPTION="Unofficial Bitwarden CLI"
307 HOMEPAGE="https://github.com/doy/rbw"
308 SRC_URI="
309         https://github.com/doy/rbw/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
310         ${CARGO_CRATE_URIS}
313 LICENSE="MIT"
314 # Dependent crate licenses
315 LICENSE+=" Apache-2.0 BSD Boost-1.0 ISC MIT Unicode-DFS-2016"
316 SLOT="0"
317 KEYWORDS="~amd64"
319 QA_FLAGS_IGNORED="
320         usr/bin/rbw
321         usr/bin/rbw-agent
324 src_install() {
325         cargo_src_install
327         local rbw
328         rbw="target/$(usex debug debug release)/rbw"
330         "$rbw" gen-completions bash > rbw || die
331         dobashcomp rbw
333         "$rbw" gen-completions fish > rbw.fish || die
334         dofishcomp rbw.fish
336         "$rbw" gen-completions zsh > _rbw || die
337         dozshcomp _rbw