1 # Copyright 2022-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 CMAKE_IN_SOURCE_BUILD=ON
8 inherit cmake systemd xdg
10 DESCRIPTION="qBittorrent Enhanced, based on qBittorrent"
11 HOMEPAGE="https://github.com/c0re100/qBittorrent-Enhanced-Edition"
13 SRC_URI="https://github.com/c0re100/qBittorrent-Enhanced-Edition/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
14 S="${WORKDIR}/qBittorrent-Enhanced-Edition-release-${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="+dbus webui +gui"
21 REQUIRED_USE="dbus? ( gui )
26 >=dev-libs/boost-1.65.0-r1:=
28 net-libs/libtorrent-rasterbar
32 dev-qt/qtbase:6[network,ssl,sql,xml]
34 dev-qt/qtbase:6[gui,widgets]
37 dbus? ( dev-qt/qtbase:6[dbus] )
41 BDEPEND="dev-qt/qttools:6
44 DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md)
47 "${FILESDIR}/4.5-fix-compile-error-when-disable-webui.patch"
62 -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
64 -DVERBOSE_CONFIGURE=ON