1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop unpacker xdg
9 DESCRIPTION
="Based on the Bilibli offcial client to linux version, support roaming"
10 HOMEPAGE
="https://github.com/msojocs/bilibili-linux"
11 BASE_URI
="https://github.com/msojocs/bilibili-linux/releases/download/v${MY_PV}"
12 FPN
="io.github.msojocs.${PN}"
13 SRC_URI
="${BASE_URI}/${FPN}_${MY_PV}_amd64.deb"
30 wayland? ( dev-libs/wayland )
39 doicon
-s "scalable" "usr/share/icons/hicolor/scalable/apps/${FPN}.svg"
40 domenu
"usr/share/applications/${FPN}.desktop"
41 fperms
+x
"/opt/apps/${FPN}/files/bin/bin/bilibili"
42 fperms
+x
"/opt/apps/${FPN}/files/bin/electron/"{electron
,chrome_crashpad_handler
,chrome-sandbox
}