net-fs/ksmbd: fix CONFIG_CHECK
[gentoo-zh.git] / app-vim / clang_complete / clang_complete-1.8.ebuild
blob1d4a756909dcccd3618a113fc9ddc37bb73205b4
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 VIM_PLUGIN_VIM_VERSION="7.3"
7 inherit vim-plugin
9 DESCRIPTION="vim plugin: use clang for completing C/C++ code."
10 HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3526"
11 SRC_URI="https://github.com/xavierd/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="as-is"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
16 RDEPEND="${DEPEND}
17 || ( app-editors/vim[python] app-editors/gvim[python] )
18 >=dev-lang/python-2.3
19 sys-devel/clang"
21 VIM_PLUGIN_HELPFILES="${PN}"
23 src_prepare() {
24 default
26 rm Makefile
29 src_install() {
30 dodoc README
31 rm .gitignore README
32 vim-plugin_src_install