1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 if [[ "${PV}" == 9999 ]]; then
10 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-chinese-addons.git"
13 SRC_URI="https://github.com/fcitx/fcitx5-chinese-addons/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
14 KEYWORDS="~amd64 ~x86"
18 https://download.fcitx-im.org/data/py_stroke-20121124.tar.gz -> fcitx-data-py_stroke-20121124.tar.gz
19 https://download.fcitx-im.org/data/py_table-20121124.tar.gz -> fcitx-data-py_table-20121124.tar.gz
22 DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
23 HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
25 LICENSE="BSD-1 GPL-2+ LGPL-2+ MIT"
27 IUSE="+opencc +gui browser test"
30 RDEPEND="app-i18n/fcitx5
32 opencc? ( app-i18n/opencc:= )
37 app-i18n/fcitx5-qt[qt5,-only_plugin]
43 kde-frameworks/extra-cmake-modules:5
47 ln -s "${DISTDIR}/fcitx-data-py_stroke-20121124.tar.gz" modules/pinyinhelper/py_stroke-20121124.tar.gz || die
48 ln -s "${DISTDIR}/fcitx-data-py_table-20121124.tar.gz" modules/pinyinhelper/py_table-20121124.tar.gz || die
54 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
55 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
56 -DENABLE_GUI=$(usex gui)
57 -DENABLE_OPENCC=$(usex opencc)
58 -DENABLE_BROWSER=$(usex browser)