net-im/wemeet: Wemeet - Tencent Video Conferencing (#1186)
[gentoo-zh.git] / app-i18n / fcitx5-gtk / fcitx5-gtk-5.0.7.ebuild
blobb8de944fe8490543613f631396d4f9d1b8de702d
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit cmake gnome2-utils xdg
8 if [[ "${PV}" == 9999 ]]; then
9         inherit git-r3
10         EGIT_REPO_URI="https://github.com/fcitx/fcitx5-gtk.git"
11         KEYWORDS=""
12 else
13         SRC_URI="https://github.com/fcitx/fcitx5-gtk/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
14         KEYWORDS="~amd64 ~x86"
17 DESCRIPTION="Gtk im module for fcitx5 and glib based dbus client library"
18 HOMEPAGE="https://github.com/fcitx/fcitx5-gtk"
20 LICENSE="BSD-1 GPL-2+ LGPL-2+ MIT"
21 SLOT="5"
22 IUSE="+gtk2 +gtk3 +introspection +snooper"
24 RDEPEND="app-i18n/fcitx5
25         gtk2? ( x11-libs/gtk+:2 )
26         gtk3? ( x11-libs/gtk+:3 )
27         introspection? ( dev-libs/gobject-introspection )
28         kde-frameworks/extra-cmake-modules"
29 DEPEND="${RDEPEND}
30         virtual/pkgconfig"
32 PATCHES=("${FILESDIR}/${P}-fix-missing-include.patch")
34 src_prepare() {
35         cmake_src_prepare
38 src_configure() {
39         local mycmakeargs=(
40                 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
41                 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
42                 -DCMAKE_BUILD_TYPE=Release
43                 -DENABLE_GTK2_IM_MODULE=$(usex gtk2)
44                 -DENABLE_GTK3_IM_MODULE=$(usex gtk3)
45                 -DENABLE_GTK4_IM_MODULE=OFF
46                 -DENABLE_SNOOPER=$(usex snooper)
47                 -DENABLE_GIR=$(usex introspection)
48         )
49         cmake_src_configure
52 pkg_postinst() {
53         xdg_pkg_postinst
54         use gtk2 && gnome2_query_immodules_gtk2
55         use gtk3 && gnome2_query_immodules_gtk3
58 pkg_postrm() {
59         xdg_pkg_postrm
60         use gtk2 && gnome2_query_immodules_gtk2
61         use gtk3 && gnome2_query_immodules_gtk3