net-im/wemeet: Wemeet - Tencent Video Conferencing (#1186)
[gentoo-zh.git] / net-dialup / mentohust / mentohust-9999.ebuild
blob17b242494d6456849f45bf236ca63813a0eaa23c
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit eutils autotools subversion
8 DESCRIPTION="A Ruijie and Cernet supplicant on Linux and MacOS"
9 HOMEPAGE="http://code.google.com/p/mentohust/"
10 ESVN_REPO_URI="http://mentohust.googlecode.com/svn/trunk/"
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="debug libnotify +nls +arp +encryptpwd"
17 RDEPEND="
18         net-libs/libpcap
19         libnotify? ( x11-libs/libnotify )
20         "
21 DEPEND="${RDEPEND}"
23 src_unpack() {
24         subversion_src_unpack
25         cd "${S}"
26         sh autogen.sh
29 src_compile() {
30         econf \
31                 $(use_enable nls) \
32                 $(use_enable libnotify notify) \
33                 $(use_enable debug) \
34                 $(use_enable arp) \
35                 $(use_enable encryptpwd encodepass)
37         emake || die "emake failed"