1 # Copyright 2020-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit cmake-utils git-r3
8 DESCRIPTION="Plugin for Qv2ray to support Trojan proxy in Qv2ray"
9 HOMEPAGE="https://github.com/Qv2ray/QvPlugin-Trojan"
10 EGIT_REPO_URI="${HOMEPAGE}.git"
11 EGIT_SUBMODULES=( '*' '-*/libsodium' '-*/libuv' )
14 KEYWORDS="~amd64 ~x86"
18 IUSE="tcpfastopen nat reuseport"
21 <net-proxy/qv2ray-2.7.0
23 >=dev-libs/openssl-1.1.1
30 -DENABLE_SSL_KEYLOG=ON
31 -DENABLE_TLS13_CIPHERSUITES=ON
32 -DFORCE_TCP_FASTOPEN=$(usex tcpfastopen)
33 -DENABLE_NAT=$(usex nat)
34 -DENABLE_REUSE_PORT=$(usex reuseport)
36 cmake-utils_src_configure
40 insinto "/usr/share/qv2ray/plugins"
42 doins "${BUILD_DIR}/libQvTrojanPlugin.so"