net-im/wemeet: Wemeet - Tencent Video Conferencing (#1186)
[gentoo-zh.git] / sci-libs / libticables2 / libticables2-9999.ebuild
blob9ede4eb7a5d0d7104daf2efb34b3db23cbe834d8
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools eutils git-r3
8 DESCRIPTION="Library to handle different link cables for TI calculators"
9 HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
10 SRC_URI=""
12 EGIT_REPO_URI="https://github.com/debrouxl/tilibs.git"
14 MY_PN="libticables"
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE="debug doc nls static-libs usb"
21 RDEPEND="
22 dev-libs/glib:2
23 usb? ( virtual/libusb:1 )
24 nls? ( virtual/libintl )"
26 DEPEND="${RDEPEND}
27 virtual/pkgconfig
28 nls? ( sys-devel/gettext )"
30 DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
32 src_prepare() {
33 S="${S}/${MY_PN}/trunk/"
34 cd "${S}"
35 eautoreconf
38 src_configure() {
39 # if both libusb and libusb10 was set, libusb10 will be used.
40 econf \
41 --disable-rpath \
42 $(use_enable debug logging) \
43 $(use_enable usb libusb) \
44 $(use_enable usb libusb10) \
45 $(use_enable nls) \
46 $(use_enable static-libs static)
49 src_install() {
50 default
51 use doc && dohtml docs/html/*
54 pkg_postinst() {
55 elog "Please read README in /usr/share/doc/${PF}"
56 elog "if you encounter any problem with a link cable"