1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools eutils git-r3
8 DESCRIPTION
="Library to handle different link cables for TI calculators"
9 HOMEPAGE
="http://lpg.ticalc.org/prj_tilp/"
12 EGIT_REPO_URI
="https://github.com/debrouxl/tilibs.git"
19 IUSE
="debug doc nls static-libs usb"
23 usb? ( virtual/libusb:1 )
24 nls? ( virtual/libintl )"
28 nls? ( sys-devel/gettext )"
30 DOCS
=( AUTHORS LOGO NEWS README ChangeLog docs
/api.txt
)
33 S
="${S}/${MY_PN}/trunk/"
39 # if both libusb and libusb10 was set, libusb10 will be used.
42 $
(use_enable debug logging
) \
43 $
(use_enable usb libusb
) \
44 $
(use_enable usb libusb10
) \
46 $
(use_enable static-libs static
)
51 use doc
&& dohtml docs
/html
/*
55 elog
"Please read README in /usr/share/doc/${PF}"
56 elog
"if you encounter any problem with a link cable"