net-im/wemeet: Wemeet - Tencent Video Conferencing (#1186)
[gentoo-zh.git] / sci-libs / libticalcs2 / libticalcs2-9999.ebuild
blob8358985fe1ecfca42b4e28ea5efba7ca8f0a8661
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools eutils git-r3
8 DESCRIPTION="Library for communication with TI calculators"
9 HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
10 SRC_URI=""
12 EGIT_REPO_URI="https://github.com/debrouxl/tilibs.git"
14 MY_PN="libticalcs"
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE="doc nls static-libs"
21 RDEPEND="
22 dev-libs/glib:2
23 >=sci-libs/libticables2-1.3.3
24 >=sci-libs/libticonv-1.1.3
25 >=sci-libs/libtifiles2-1.1.5
26 nls? ( virtual/libintl )"
27 DEPEND="${RDEPEND}
28 virtual/pkgconfig
29 nls? ( sys-devel/gettext )"
31 DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
33 src_prepare() {
34 S="${S}/${MY_PN}/trunk/"
35 cd "${S}"
37 eautoreconf
40 src_configure() {
41 econf \
42 --disable-rpath \
43 $(use_enable nls) \
44 $(use_enable static-libs static)
47 src_install() {
48 default
49 use doc && dohtml docs/html/*