net-im/wemeet: Wemeet - Tencent Video Conferencing (#1186)
[gentoo-zh.git] / sys-devel / ucc / ucc-1.1-r0.ebuild
blob3c6f234077dc68186a462428f89a1bd97fb48df7
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit eutils
8 DESCRIPTION="UCC is an ANSI C Compiler"
9 HOMEPAGE="https://sourceforge.net/projects/ucc"
10 ECVS_CVS_OPTIONS="-dP -z3"
11 SRC_URI="mirror://sourceforge/ucc/${PN}160.zip"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
17 RESTRICT="mirror"
18 IUSE=""
20 DEPEND=""
21 RDEPEND=""
23 S="${WORKDIR}/${PN}"
25 src_prepare() {
26 default
27 sed -i -e 's:/usr/local/lib/ucc/:/usr/lib/ucc/:' "${S}/driver/linux.c"
28 sed -i -e 's:UCCDIR \"ucl\":\"/usr/bin/ucl\":' "${S}/driver/linux.c"
31 src_install() {
32 dodir /usr/lib/ucc
33 dodir /usr/bin
34 dobin driver/ucc
35 dobin ucl/ucl
36 dodir /usr/lib/ucc
37 insinto /usr/lib/ucc
38 doins ucl/assert.o
39 dodir /usr/include/ucc
40 cp -r ucl/linux/include/* "${D}"/usr/include/ucc