net-im/wemeet: Wemeet - Tencent Video Conferencing (#1186)
[gentoo-zh.git] / x11-misc / i3lock-fancy / i3lock-fancy-9999.ebuild
blob3aeae3d7ccb2985ec0cffdcdcc30e00d845f2227
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=6
6 inherit git-r3
8 DESCRIPTION="A fancy i3lock"
9 HOMEPAGE="https://github.com/meskarune/i3lock-fancy"
10 EGIT_REPO_URI="https://github.com/meskarune/i3lock-fancy.git"
11 LICENSE="BSD"
12 SRC_URI=""
13 KEYWORDS=""
14 SLOT="0"
16 RDEPEND="app-shells/bash:0
17                 media-gfx/imagemagick
18                 virtual/awk
19                 x11-misc/wmctrl
20                 media-gfx/scrot
21                 x11-misc/i3lock-color"
23 DEPEND="${RDEPEND}"
25 INST_DIR="${D}/usr/share/i3lock-fancy"
27 src_configure() {
28         # Fix script requiring icons to be in same dir
29         sed 's,$(readlink -f -- "$0"),"/usr/share/i3lock-fancy/",' lock > lock.sh
30         sed -i 's/\/usr/$DESTDIR\/usr/g' Makefile
33 src_install() {
34         mkdir -p "$INST_DIR" "${D%/*}/usr/bin/"
35         cp lock.sh "${D}/usr/bin/lock"
36         chmod +x "${D}/usr/bin/lock"
37         cp -r icons "${INST_DIR}"