1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION="A fancy i3lock"
9 HOMEPAGE="https://github.com/meskarune/i3lock-fancy"
10 EGIT_REPO_URI="https://github.com/meskarune/i3lock-fancy.git"
16 RDEPEND="app-shells/bash:0
21 x11-misc/i3lock-color"
25 INST_DIR="${D}/usr/share/i3lock-fancy"
28 # Fix script requiring icons to be in same dir
29 sed 's,$(readlink -f -- "$0"),"/usr/share/i3lock-fancy/",' lock > lock.sh
30 sed -i 's/\/usr/$DESTDIR\/usr/g' Makefile
34 mkdir -p "$INST_DIR" "${D%/*}/usr/bin/"
35 cp lock.sh "${D}/usr/bin/lock"
36 chmod +x "${D}/usr/bin/lock"
37 cp -r icons "${INST_DIR}"