1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 if [[ "${PV}" == 9999 ]]; then
10 EGIT_REPO_URI
="https://github.com/fcitx/fcitx5-chinese-addons.git"
12 MY_PN
="fcitx5-chinese-addons"
13 S
="${WORKDIR}/${MY_PN}-${PV}"
14 SRC_URI
="https://github.com/fcitx/fcitx5-chinese-addons/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
15 KEYWORDS
="~amd64 ~x86"
19 https://download.fcitx-im.org/data/py_stroke-20121124.tar.gz -> fcitx-data-py_stroke-20121124.tar.gz
20 https://download.fcitx-im.org/data/py_table-20121124.tar.gz -> fcitx-data-py_table-20121124.tar.gz
23 DESCRIPTION
="Addons related to Chinese, including IME previous bundled inside fcitx4."
24 HOMEPAGE
="https://github.com/fcitx/fcitx5-chinese-addons"
26 LICENSE
="BSD-1 GPL-2+ LGPL-2+ MIT"
28 IUSE
="browser +gui lua +opencc test"
30 RESTRICT
="!test? ( test )"
35 opencc? ( app-i18n/opencc:= )
38 app-i18n/fcitx-qt:5[qt5,-onlyplugin]
39 browser? ( dev-qt/qtwebengine:5 )
40 lua? ( app-i18n/fcitx-lua:5 )
44 kde-frameworks/extra-cmake-modules:5
48 ln -s "${DISTDIR}/fcitx-data-py_stroke-20121124.tar.gz" modules
/pinyinhelper
/py_stroke-20121124.
tar.gz || die
49 ln -s "${DISTDIR}/fcitx-data-py_table-20121124.tar.gz" modules
/pinyinhelper
/py_table-20121124.
tar.gz || die
55 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
56 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
57 -DENABLE_GUI=$
(usex gui
)
58 -DENABLE_OPENCC=$
(usex opencc
)
59 -DENABLE_BROWSER=$
(usex browser
)