media-gfx/zwcad: add 2023.23.0.3.4
[gentoo-zh.git] / app-i18n / fcitx-chinese-addons / fcitx-chinese-addons-9999.ebuild
blobc33c3665ed28c4ac2f50073bf12333e2339894fd
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake xdg
8 if [[ "${PV}" == 9999 ]]; then
9 inherit git-r3
10 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-chinese-addons.git"
11 else
12 MY_PN="fcitx5-chinese-addons"
13 S="${WORKDIR}/${MY_PN}-${PV}"
14 SRC_URI="https://github.com/fcitx/fcitx5-chinese-addons/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
15 KEYWORDS="~amd64 ~x86"
18 SRC_URI+="
19 https://download.fcitx-im.org/data/py_stroke-20121124.tar.gz -> fcitx-data-py_stroke-20121124.tar.gz
20 https://download.fcitx-im.org/data/py_table-20121124.tar.gz -> fcitx-data-py_table-20121124.tar.gz
23 DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
24 HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
26 LICENSE="BSD-1 GPL-2+ LGPL-2+ MIT"
27 SLOT="5"
28 IUSE="browser +gui lua +opencc test"
29 REQUIRED_USE=""
30 RESTRICT="!test? ( test )"
32 RDEPEND="
33 app-i18n/fcitx:5
34 app-i18n/libime
35 opencc? ( app-i18n/opencc:= )
36 gui? (
37 dev-qt/qtcore:5
38 app-i18n/fcitx-qt:5[qt5,-onlyplugin]
39 browser? ( dev-qt/qtwebengine:5 )
40 lua? ( app-i18n/fcitx-lua:5 )
43 DEPEND="${RDEPEND}
44 kde-frameworks/extra-cmake-modules:5
45 virtual/pkgconfig"
47 src_prepare() {
48 ln -s "${DISTDIR}/fcitx-data-py_stroke-20121124.tar.gz" modules/pinyinhelper/py_stroke-20121124.tar.gz || die
49 ln -s "${DISTDIR}/fcitx-data-py_table-20121124.tar.gz" modules/pinyinhelper/py_table-20121124.tar.gz || die
50 cmake_src_prepare
53 src_configure() {
54 local mycmakeargs=(
55 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
56 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
57 -DENABLE_GUI=$(usex gui)
58 -DENABLE_OPENCC=$(usex opencc)
59 -DENABLE_BROWSER=$(usex browser)
60 -DUSE_WEBKIT=no
62 cmake_src_configure