1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 if [[ "${PV}" == 9999 ]]; then
10 EGIT_REPO_URI
="https://github.com/fcitx/fcitx5-configtool.git"
12 MY_PN
="fcitx5-configtool"
13 S
="${WORKDIR}/${MY_PN}-${PV}"
14 SRC_URI
="https://github.com/fcitx/fcitx5-configtool/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
15 KEYWORDS
="~amd64 ~x86"
18 DESCRIPTION
="Configuration module for Fcitx"
19 HOMEPAGE
="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-configtool"
23 IUSE
="+kcm +config-qt test"
24 RESTRICT
="!test? ( test )"
26 RDEPEND
="app-i18n/fcitx:5
27 app-i18n/fcitx-qt:5[qt5,-onlyplugin]
33 kde-frameworks/kwidgetsaddons:5
38 kde-frameworks/kconfigwidgets:5
39 kde-frameworks/kcoreaddons:5
40 kde-frameworks/ki18n:5
41 kde-frameworks/kirigami:5
42 kde-frameworks/kdeclarative:5
45 kde-frameworks/kitemviews:5
47 !${CATEGORY}/${PN}:4[-minimal(-)]"
50 kde-frameworks/extra-cmake-modules:5
56 -DKDE_INSTALL_USE_QT_SYS_PATHS=yes
57 -DENABLE_KCM=$
(usex kcm
)
58 -DENABLE_CONFIG_QT=$
(usex config-qt
)
59 -DENABLE_TEST=$
(usex
test)