net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / app-emulation / deepin-wine-helper / deepin-wine-helper-5.1.45.ebuild
blob797b0d9736e7ee84cf2623a6e4590f502ff5cef1
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_{8..12} )
7 inherit python-single-r1 unpacker
9 DESCRIPTION="Deepin Wine Helper"
10 HOMEPAGE="https://www.deepin.org"
12 COMMON_URI="https://home-store-packages.uniontech.com/appstore/pool/appstore/d"
13 SRC_URI="${COMMON_URI}/${PN}/${PN}_${PV}-1_i386.deb"
15 LICENSE="LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
19 RESTRICT="test"
21 RDEPEND="
22 ${PYTHON_DEPS}
24 DEPEND="${RDEPEND}"
26 S=${WORKDIR}
28 QA_PREBUILT="opt/deepinwine/*"
29 QA_FLAGS_IGNORED="opt/deepinwine/*"
31 src_install() {
32 python_fix_shebang -f "opt/deepinwine/tools/add_hotkeys"
33 python_fix_shebang -f "opt/deepinwine/tools/get_tray_window"
34 insinto /
35 doins -r opt
37 fperms +x -R /opt/deepinwine/tools/