net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / dev-python / feeluown-bilibili / feeluown-bilibili-0.4.1.ebuild
blob9c0d4c1d9b9a50ce77fb02576443142ae246548d
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 DISTUTILS_USE_PEP517=poetry
6 PYTHON_COMPAT=( python3_{10..12} )
7 PYPI_NO_NORMALIZE=true
8 inherit distutils-r1 pypi
10 DESCRIPTION="bilibili support for feeluown"
11 HOMEPAGE="https://github.com/feeluown/feeluown-bilibili"
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64"
17 RDEPEND="
18         dev-python/beautifulsoup4[${PYTHON_USEDEP}]
19         dev-python/pycryptodome[${PYTHON_USEDEP}]
20         dev-python/cachetools[${PYTHON_USEDEP}]
23 PDEPEND="
24         media-sound/feeluown
27 python_install_all() {
28         distutils-r1_python_install_all