1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 DISTUTILS_USE_PEP517=poetry
6 PYTHON_COMPAT=( python3_{10..12} )
8 inherit distutils-r1 pypi
10 DESCRIPTION="bilibili support for feeluown"
11 HOMEPAGE="https://github.com/feeluown/feeluown-bilibili"
18 dev-python/beautifulsoup4[${PYTHON_USEDEP}]
19 dev-python/pycryptodome[${PYTHON_USEDEP}]
20 dev-python/cachetools[${PYTHON_USEDEP}]
27 python_install_all() {
28 distutils-r1_python_install_all