net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / dev-python / fuo-qqmusic / fuo-qqmusic-1.0.5.ebuild
blobc273407c376cd2d148300addf462d9889d57702a
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 DISTUTILS_USE_PEP517=setuptools
6 PYTHON_COMPAT=( python3_{9..12} pypy)
8 inherit distutils-r1 pypi
10 DESCRIPTION="qq music support for feeluown"
11 HOMEPAGE="https://github.com/feeluown/feeluown-qqmusic"
13 LICENSE="GPL-3"
14 SLOT="1"
15 KEYWORDS="~amd64"
17 RDEPEND="
18 dev-python/marshmallow[${PYTHON_USEDEP}]
19 dev-python/requests[${PYTHON_USEDEP}]
21 PDEPEND="
22 media-sound/feeluown
25 python_install_all() {
26 distutils-r1_python_install_all