net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / dev-python / pytube / pytube-15.0.0.ebuild
blob3e71288de486bfb85bc4f9b4c8bc38f5134dd406
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
5 DISTUTILS_USE_PEP517=setuptools
6 PYTHON_COMPAT=( python3_{9..12} pypy3 )
8 inherit distutils-r1 pypi
10 DESCRIPTION="Python tools for downloading YouTube Videos"
11 HOMEPAGE="https://github.com/pytube/pytube"
12 LICENSE="Unlicense"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
18 DEPEND="
19 dev-python/setuptools[${PYTHON_USEDEP}]
20 test? (
21 dev-python/pytest[${PYTHON_USEDEP}]
22 dev-python/pytest-mock[${PYTHON_USEDEP}]
26 python_test() {
27 py.test -v || die "Tests fail with ${EPYTHON}"
30 python_install_all() {
31 distutils-r1_python_install_all