1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit bash-completion-r1
8 DESCRIPTION
="Manage all your runtime versions with one tool"
9 HOMEPAGE
="https://github.com/asdf-vm/asdf"
10 SRC_URI
="https://github.com/asdf-vm/asdf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 S
="${WORKDIR}/asdf-${PV}"
15 KEYWORDS
="amd64 arm64"
22 DOCS
=( CHANGELOG.md README.md
)
30 doins asdf.
{elv
,fish
,nu
,ps1
,sh
}
35 fperms
+x
/opt
/${PN}/bin
/asdf
36 fperms
+x
/opt
/${PN}/bin
/private
/asdf-exec
37 fperms
+x
/opt
/${PN}/asdf.
{elv
,fish
,nu
,ps1
,sh
}
39 dobashcomp completions
/asdf.bash
41 insinto
/usr
/share
/zsh
/site-functions
42 doins completions
/_asdf
44 insinto
/usr
/share
/fish
/vendor_completions.d
45 doins completions
/asdf.fish