net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / games-util / winegame-client-bin / winegame-client-bin-0.5.12.2.ebuild
bloba0b3cdf6d7e0847e417bfb4cd55c5b0239c8db86
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_{10..11} )
7 PYTHON_REQ_USE="sqlite,threads(+)"
9 inherit unpacker xdg python-r1
11 DESCRIPTION="An open source gaming platform for GNU/Linux"
12 HOMEPAGE="https://winegame.net/"
13 SRC_URI="https://file.winegame.net/packages/debian/${PV}/net.winegame.client_${PV}_amd64.deb"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20 DEPEND="app-arch/cabextract"
22 RDEPEND="
23 ${PYTHON_DEPS}
24 app-arch/unzip
25 app-arch/p7zip
26 net-misc/curl
27 net-misc/aria2
28 $(python_gen_cond_dep '
29 dev-python/dbus-python[${PYTHON_USEDEP}]
30 dev-python/pillow[${PYTHON_USEDEP}]
31 dev-python/pygobject:3[${PYTHON_USEDEP}]
32 dev-python/evdev[${PYTHON_USEDEP}]
33 dev-python/python-magic[${PYTHON_USEDEP}]
34 dev-python/pyyaml[${PYTHON_USEDEP}]
35 dev-python/requests[${PYTHON_USEDEP}]
36 dev-python/pydbus[${PYTHON_USEDEP}]
37 dev-python/distro[${PYTHON_USEDEP}]
39 gnome-base/gnome-desktop:3[introspection]
40 gnome-extra/zenity
41 net-libs/webkit-gtk:4[introspection]
42 media-sound/fluid-soundfont
43 x11-apps/mesa-progs
44 x11-apps/xrandr
45 x11-apps/xgamma
46 x11-libs/gtk+:3[introspection]
47 virtual/wine
50 S=${WORKDIR}
52 src_install() {
53 insinto /
54 doins -r usr opt
56 fperms -R 755 /opt/apps/net.winegame.client/files/bin
57 fperms -R 755 /opt/apps/net.winegame.client/files/share/lutris/bin