net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / media-fonts / smiley-sans / smiley-sans-2.0.1.ebuild
blobb4d5e0d9bf7a0de7de5b44d2d2965725b277605e
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit font
8 MY_PN="SmileySans"
9 DESCRIPTION="An open-source font for Chinese."
10 HOMEPAGE="https://github.com/atelier-anchor/smiley-sans"
11 SRC_URI="https://github.com/atelier-anchor/smiley-sans/releases/download/v${PV}/smiley-sans-v${PV}.zip -> ${P}.zip"
13 LICENSE="OFL-1.1"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 BDEPEND="app-arch/unzip"
17 S=${WORKDIR}
18 FONT_SUFFIX="ttf otf"
20 src_unpack() {
21 default
22 # rename the font files
23 mv ${MY_PN}-Oblique.otf ${MY_PN}.otf || die "Renaming otf fonts failed"
24 mv ${MY_PN}-Oblique.ttf ${MY_PN}.ttf || die "Renaming ttf fonts failed"