net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / media-fonts / tiejili / tiejili-1.100.ebuild
blobeecf8c2cfa44be19a9b7b67fa5c1a192351f1da9
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit font
8 MY_PN="Tiejili"
9 DESCRIPTION="An open-source font that extends Reggae One to Chinese."
10 HOMEPAGE="https://github.com/Buernia/Tiejili"
11 SRC_URI="https://github.com/Buernia/Tiejili/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
13 LICENSE="OFL-1.1"
14 SLOT="0"
15 KEYWORDS="~amd64"
17 S="${WORKDIR}/${MY_PN}-${PV}"
18 FONT_SUFFIX="ttf otf"
20 src_unpack() {
21 default
23 # remove README to prevent it from being installed as doc
24 rm "${S}/README.md" || die
26 # mv font files from sub-dir to ${S}
27 mv "${S}"/fonts/ttf/*.ttf "${S}"/ || die
28 mv "${S}"/fonts/otf/*.otf "${S}"/ || die