net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / media-fonts / ttf-wps-fonts / ttf-wps-fonts-9999.ebuild
blobfaadb71c862f85a47168a3e5e44a5a9bb25c2ffb
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 DISABLE_AUTOFORMATTING=true
6 inherit font unpacker git-r3
8 DESCRIPTION="Symbol fonts required by wps-office"
9 HOMEPAGE="https://github.com/iamdh4/ttf-wps-fonts"
11 LICENSE="all-rights-reserved"
12 SLOT="0"
13 KEYWORDS="amd64 arm ppc ppc64 x86"
15 EGIT_REPO_URI="https://github.com/iamdh4/ttf-wps-fonts.git"
17 FONT_SUFFIX="ttf"
19 # Only installs fonts
20 RESTRICT="binchecks strip test"
22 pkg_postinst() {
23 unset FONT_CONF # override default message
24 font_pkg_postinst
27 src_install(){
28 install -d "${D}/usr/share/fonts/wps-fonts"
29 install -m644 *.{ttf,TTF} "${D}/usr/share/fonts/wps-fonts/"