1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.4
53 bytecheck_derive@0.6.12
68 concurrent-queue@2.5.0
73 core-foundation-sys@0.8.7
74 core-foundation@0.10.0
76 core-graphics-types@0.2.0
80 crossbeam-channel@0.5.13
81 crossbeam-utils@0.8.20
91 derive_is_enum_variant@0.1.1
99 document-features@0.2.10
100 documented-macros@0.9.1
111 enumflags2_derive@0.7.10
114 event-listener-strategy@0.5.2
121 foreign-types-macros@0.2.3
122 foreign-types-shared@0.1.1
123 foreign-types-shared@0.3.1
126 form_urlencoded@1.2.1
128 from_variants_impl@1.0.2
130 futures-channel@0.3.31
132 futures-executor@0.3.31
140 gdk-pixbuf-sys@0.18.0
141 gdk-pixbuf-sys@0.20.4
196 icu_collections@1.5.0
198 icu_locid_transform@1.5.0
199 icu_locid_transform_data@1.5.0
201 icu_normalizer_data@1.5.0
203 icu_properties_data@1.5.0
205 icu_provider_macros@1.5.0
219 libappindicator-sys@0.9.0
220 libappindicator@0.9.0
226 libmimalloc-sys@0.1.39
245 minimal-lexical@0.2.1
260 objc-foundation@0.1.1
263 objc2-core-data@0.2.2
264 objc2-core-image@0.2.2
266 objc2-foundation@0.2.2
268 objc2-quartz-core@0.2.2
290 parking_lot_core@0.9.10
292 percent-encoding@2.3.1
297 pin-project-lite@0.2.15
308 proc-macro-crate@1.3.1
309 proc-macro-crate@2.0.0
310 proc-macro-crate@3.2.0
311 proc-macro-error-attr@1.0.4
312 proc-macro-error@1.0.4
316 ptr_meta_derive@0.1.4
326 raw-window-handle@0.6.2
329 regex-automata@0.1.10
342 rust_decimal_macros@1.36.0
343 rustc-demangle@0.1.24
347 rustls-pki-types@1.10.0
348 rustls-webpki@0.102.8
356 security-framework-sys@2.12.1
357 security-framework@2.11.1
364 serde_urlencoded@0.7.1
368 signal-hook-registry@1.4.2
379 stable_deref_trait@1.2.0
380 static_assertions@1.1.0
393 system-configuration-sys@0.6.0
394 system-configuration@0.6.1
398 target-lexicon@0.12.16
402 thiserror-impl@1.0.69
414 tokio-native-tls@0.3.1
424 tracing-attributes@0.1.28
426 tracing-journald@0.3.1
429 tracing-subscriber@0.3.19
437 unicode-normalization@0.1.24
438 unicode-segmentation@1.12.0
450 version-compare@0.2.0
456 wasi@0.11.0+wasi-snapshot-preview1
457 wasm-bindgen-backend@0.2.95
458 wasm-bindgen-futures@0.4.45
459 wasm-bindgen-macro-support@0.2.95
460 wasm-bindgen-macro@0.2.95
461 wasm-bindgen-shared@0.2.95
463 wayland-backend@0.3.7
464 wayland-client@0.31.7
465 wayland-protocols@0.32.5
466 wayland-scanner@0.31.5
469 winapi-i686-pc-windows-gnu@0.4.0
470 winapi-x86_64-pc-windows-gnu@0.4.0
473 windows-implement@0.58.0
474 windows-interface@0.58.0
475 windows-registry@0.2.0
477 windows-strings@0.1.0
481 windows-targets@0.48.5
482 windows-targets@0.52.6
484 windows_aarch64_gnullvm@0.48.5
485 windows_aarch64_gnullvm@0.52.6
486 windows_aarch64_msvc@0.48.5
487 windows_aarch64_msvc@0.52.6
488 windows_exe_info@0.4.2
489 windows_i686_gnu@0.48.5
490 windows_i686_gnu@0.52.6
491 windows_i686_gnullvm@0.52.6
492 windows_i686_msvc@0.48.5
493 windows_i686_msvc@0.52.6
494 windows_x86_64_gnu@0.48.5
495 windows_x86_64_gnu@0.52.6
496 windows_x86_64_gnullvm@0.48.5
497 windows_x86_64_gnullvm@0.52.6
498 windows_x86_64_msvc@0.48.5
499 windows_x86_64_msvc@0.52.6
517 zerocopy-derive@0.7.35
519 zerofrom-derive@0.1.4
522 zerovec-derive@0.10.3
526 zvariant_derive@4.2.0
527 zvariant_derive@5.1.0
532 declare -A GIT_CRATES
=(
533 [dark-light
]='https://github.com/frewsxcv/rust-dark-light;3eb3e93dd0fa30733c3e93082dd9517fb580ae95;rust-dark-light-%commit%'
536 PLOCALES
="en_US it_IT zh_CN"
537 PLOCALE_BACKUP
="en_US"
539 inherit cargo desktop gnome2-utils plocale xdg
541 DESCRIPTION
="Simple On Screen lyrics Display for linux/unix"
543 https://waylyrics.github.io/waylyrics/waylyrics
544 https://github.com/waylyrics/waylyrics
547 if [[ "${PV}" == *9999* ]]; then
549 EGIT_REPO_URI
="https://github.com/waylyrics/waylyrics.git"
552 https://github.com/waylyrics/waylyrics/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
555 KEYWORDS
="~amd64 ~loong"
558 LICENSE
="MIT CC-BY-4.0"
559 # Dependent crate licenses
561 Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD GPL-3+ ISC MIT
562 MPL-2.0 Unicode-3.0 Unicode-DFS-2016 Unlicense
578 sys-apps/xdg-desktop-portal
582 export WAYLYRICS_THEME_PRESETS_DIR
="/usr/share/${PN}/themes"
583 cargo_src_compile
--all-targets --all-features
589 doicon
-s scalable
"${S}/res/icons/hicolor/scalable/apps/io.github.waylyrics.Waylyrics.svg"
590 domenu
"${S}/metainfo/io.github.waylyrics.Waylyrics.desktop"
592 insinto
"/usr/share/glib-2.0/schemas"
593 doins
"${S}/metainfo/io.github.waylyrics.Waylyrics.gschema.xml"
595 insinto
"/usr/share/metainfo"
596 doins
"${S}/metainfo/io.github.waylyrics.Waylyrics.metainfo.xml"
598 insinto
"/usr/share/${PN}"
601 cd "${S}/locales" || die
603 if [[ -f ${1}/LC_MESSAGES
/waylyrics.po
]]; then
604 local file=${1}/LC_MESSAGES
/waylyrics.po
605 msgfmt
"${file}" -o "${file%.po}.mo" || die
606 insinto
/usr
/share
/locale
/${1}/LC_MESSAGES
607 doins
"${file%.po}.mo"
610 plocale_for_each_locale install_locale
614 gnome2_schemas_update
619 gnome2_schemas_update