net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / net-analyzer / realitlscanner / realitlscanner-0.2.1.ebuild
blob55a17f0179b86e444fb5b3d7a16cd7b40d6fba14
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit go-module
7 DESCRIPTION="A TLS server scanner for Reality"
8 HOMEPAGE="https://github.com/XTLS/RealiTLScanner"
10 SRC_URI="
11 https://github.com/XTLS/RealiTLScanner/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
12 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
15 S="${WORKDIR}/RealiTLScanner-${PV}"
16 LICENSE="MPL-2.0"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm64"
20 src_compile() {
21 local ldflags="\
22 -w -s"
23 ego build -o ${P} -trimpath -ldflags "${ldflags}"
26 src_install() {
27 newbin ${P} ${PN}