net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / net-dns / mosdns-cn-bin / mosdns-cn-bin-1.4.0-r1.ebuild
blob4d7f5ffa0ec99b8d1006cca9dfe704e7bae62397
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="A DNS forwarder"
7 HOMEPAGE="https://github.com/IrineSistiana/mosdns-cn"
8 SRC_URI="https://github.com/IrineSistiana/mosdns-cn/releases/download/v${PV}/mosdns-cn-linux-amd64.zip -> ${P}.zip"
10 S=${WORKDIR}
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64"
16 DEPEND="
17 app-alternatives/v2ray-geoip
18 app-alternatives/v2ray-geosite
20 RDEPEND="${DEPEND}"
21 BDEPEND="app-arch/unzip"
22 QA_PREBUILT="
23 /usr/bin/mosdns-cn
26 src_install() {
27 dobin mosdns-cn
29 dosym -r /usr/share/v2ray/geoip.dat /etc/mosdns/geoip.dat
30 dosym -r /usr/share/v2ray/geosite.dat /etc/mosdns/geosite.dat
32 insinto /etc/mosdns
33 newins config-template.yaml config.yaml
35 _PN=mosdns-cn
36 newinitd "${FILESDIR}/${_PN}.initd" ${_PN}
37 newconfd "${FILESDIR}/${_PN}.confd" ${_PN}