net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / net-misc / aliyunpan / aliyunpan-0.3.4.ebuild
blob717eca35e69a22e0a9c78ad96a9e028e6a6e4758
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit go-module
8 DESCRIPTION="aliyunpan cli client, support Webdav service, JavaScript plugin"
9 HOMEPAGE="https://github.com/tickstep/aliyunpan"
11 SRC_URI="https://github.com/tickstep/aliyunpan/archive/v${PV}.tar.gz -> ${P}.tar.gz
12 https://github.com/123485k/gentoo-go-deps/releases/download/${P}/${P}-deps.tar.xz"
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~s390 ~x86"
17 src_compile() {
18 ego build -o bin/${PN} -trimpath
21 src_install() {
22 dobin bin/${PN}
25 pkg_postinst() {
26 elog "if you see \"FATAL ERROR: config file error: config file permission denied\""
27 elog "try \"mkdir ~/.aliyunpan\""