net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / net-p2p / amule-dlp-antileech / amule-dlp-antileech-9999.ebuild
blob7f3aeb1ed298b9cb65837ecad5017e583b8f7e37
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 WX_GTK_VER="3.0"
7 inherit autotools git-r3 wxwidgets
8 DESCRIPTION="$PN, dynamic DLP library for amule-dlp"
9 HOMEPAGE="https://github.com/persmule/amule-dlp.antileech"
10 EGIT_REPO_URI="https://github.com/persmule/amule-dlp.antiLeech.git"
12 LICENSE="GPL-2"
13 SLOT="0"
14 IUSE="X"
16 DEPEND="x11-libs/wxGTK:${WX_GTK_VER}"
17 RDEPEND="net-p2p/amule-dlp[dynamic]"
19 src_prepare() {
20 default
21 eautoreconf || die
24 src_configure() {
25 if use X; then
26 einfo "wxGTK with X / GTK support will be used"
27 need-wxwidgets unicode
28 else
29 einfo "wxGTK without X support will be used"
30 need-wxwidgets base-unicode
33 econf
36 src_install() {
37 emake DESTDIR="${D}" install || die