1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
7 inherit wxwidgets xdg-utils autotools git-r3
8 DESCRIPTION
="aMule with DLP patch, the all-platform eMule p2p client"
9 HOMEPAGE
="https://github.com/persmule/amule-dlp"
10 EGIT_REPO_URI
="https://github.com/persmule/amule-dlp"
14 IUSE
="daemon debug geoip nls remote stats upnp +X"
19 sys-libs/binutils-libs:0=
22 >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X?]
23 daemon? ( acct-user/amule )
24 geoip? ( dev-libs/geoip )
25 nls? ( virtual/libintl )
30 stats? ( media-libs/gd:=[jpeg,png] )
31 upnp? ( net-libs/libupnp:0 )
35 X? ( dev-util/desktop-file-utils )
39 nls? ( sys-devel/gettext )
49 if [[ ${PV} == 9999 ]]; then
56 --with-denoise-level=0
57 --with-wx-config="${WX_CONFIG}"
61 $
(use_enable daemon amule-daemon
)
64 $
(use_enable remote webserver
)
65 $
(use_enable stats cas
)
66 $
(use_enable stats alcc
)
72 $
(use_enable remote amule-gui
)
73 $
(use_enable stats alc
)
74 $
(use_enable stats wxcas
)
92 newconfd
"${FILESDIR}"/amuled.confd-r1 amuled
93 newinitd
"${FILESDIR}"/amuled.initd amuled
96 newconfd
"${FILESDIR}"/amuleweb.confd-r1 amuleweb
97 newinitd
"${FILESDIR}"/amuleweb.initd amuleweb
100 if use daemon || use remote
; then
101 keepdir
/var
/lib
/${PN}
102 fowners amule
:amule
/var
/lib
/${PN}
103 fperms
0750 /var
/lib
/${PN}
110 if use daemon || use remote
; then
111 for ver
in ${REPLACING_VERSIONS}; do
112 if ver_test
${ver} -lt "2.3.2-r4"; then
113 elog
"Default user under which amuled and amuleweb daemons are started"
114 elog
"have been changed from p2p to amule. Default home directory have been"
115 elog
"changed as well."
117 elog
"If you want to preserve old download/share location, you can create"
118 elog
"symlink /var/lib/amule/.aMule pointing to the old location and adjust"
119 elog
"files ownership *or* restore AMULEUSER and AMULEHOME variables in"
120 elog
"/etc/conf.d/{amuled,amuleweb} to the old values."
127 use X
&& xdg_desktop_database_update
131 use X
&& xdg_desktop_database_update