net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / sys-apps / wait-online / wait-online-9999.ebuild
blob989b03614230d22d25632673aa3518c127ae8a91
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_{9..11} )
8 inherit git-r3 systemd python-r1
10 DESCRIPTION="Wait until we're connected to the Internet"
11 HOMEPAGE="https://github.com/lilydjwg/wait-online"
12 EGIT_REPO_URI="https://github.com/lilydjwg/wait-online"
14 LICENSE="GPL-3"
15 SLOT="0"
16 # KEYWORDS="~amd64"
17 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
19 DEPEND="
20         ${PYTHON_DEPS}
21         dev-python/python-systemd[${PYTHON_USEDEP}]
23 RDEPEND="${DEPEND}"
25 src_install(){
26         # python_fix_shebang wait-online check-online
27         dobin wait-online check-online
28         python_replicate_script "${ED}"/usr/bin/{wait-online,check-online}
29         systemd_dounit wait-online.service wait-online-onresume.service
30         insinto /usr/lib/tmpfiles.d/
31         newins tmpfiles.conf ${PN}.conf
32         dosym ../network-online.target /usr/lib/systemd/system/multi-user.target.wants/network-online.target