1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 MY_PV
=$
(ver_cut
1-3)-$
(ver_cut
4).$
(ver_cut
5)
10 DESCRIPTION
="Next generation information browser"
13 https://github.com/RSSNext/Follow
16 https://github.com/RSSNext/Follow/releases/download/v${MY_PV}/Follow-${MY_PV}-linux-x64.AppImage -> ${P}.AppImage
28 x11-libs/gtk+:3[X,cups]
33 mkdir
-p "${S}" || die
34 cp "${DISTDIR}/${P}.AppImage" "${S}" || die
36 cd "${S}" || die
# "appimage-extract" unpacks to current directory.
37 chmod +x
"${S}/${P}.AppImage" || die
38 "${S}/${P}.AppImage" --appimage-extract || die
42 cd "${S}/squashfs-root" || die
45 doicon
-s 256 usr
/share
/icons
/hicolor
/256x256
/apps
/Follow.png
52 LICENSES.chromium.html
55 rm -f -r "${toremove[@]}" || die
57 local apphome
="/opt/${PN}"
61 fperms
+x
"${apphome}/Follow"
62 dosym
-r "${apphome}/Follow" "/opt/bin/Follow"