net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / x11-misc / i3lock-fancy / i3lock-fancy-9999.ebuild
blobd875881fc346d21e34d5f0e39facd58ae2305d3b
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit git-r3
8 DESCRIPTION="A fancy i3lock"
9 HOMEPAGE="https://github.com/meskarune/i3lock-fancy"
10 EGIT_REPO_URI="https://github.com/meskarune/i3lock-fancy.git"
11 LICENSE="BSD"
12 SLOT="0"
14 RDEPEND="app-shells/bash:0
15 media-gfx/imagemagick
16 app-alternatives/awk
17 x11-misc/wmctrl
18 media-gfx/scrot
19 x11-misc/i3lock-color"
21 DEPEND="${RDEPEND}"
23 src_configure() {
24 # Fix script requiring icons to be in same dir
25 sed 's,$(readlink -f -- "$0"),"/usr/share/i3lock-fancy/",' lock > lock.sh
26 sed -i 's/\/usr/$DESTDIR\/usr/g' Makefile
29 src_install() {
30 newbin lock.sh lock
32 insinto "/usr/share/i3lock-fancy"
33 doins -r icons