net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / x11-wm / chamferwm / chamferwm-9999.ebuild
blob3c4bbaad195b36c355bce651543bd2262ddb5c35
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="A tiling X11 window manager with Vulkan compositor."
7 HOMEPAGE="https://github.com/jaelpark/chamferwm"
9 EGIT_REPO_URI="https://github.com/jaelpark/chamferwm.git git://github.com/jaelpark/chamferwm.git"
11 inherit desktop git-r3 meson xdg
13 LICENSE="BSD"
14 SLOT="0"
16 DEPEND="
17 dev-libs/boost[python]
18 media-libs/shaderc
19 dev-util/vulkan-headers
20 media-libs/vulkan-loader
23 RDEPEND="
24 media-libs/vulkan-loader
25 dev-libs/boost[python]
28 src_prepare(){
29 sed -i "s/python3')/python-3.7')/g" meson.build
32 src_install(){
33 into /usr
34 dobin "${BUILD_DIR}/chamfer"
36 insinto /usr/share/chamfer/shaders
38 doins "${BUILD_DIR}/default_fragment.spv"
39 doins "${BUILD_DIR}/default_geometry.spv"
40 doins "${BUILD_DIR}/default_vertex.spv"
41 doins "${BUILD_DIR}/frame_fragment.spv"
42 doins "${BUILD_DIR}/frame_geometry.spv"
43 doins "${BUILD_DIR}/frame_vertex.spv"
45 domenu "${S}/share/chamfer.desktop"