1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DESCRIPTION
="A tiling X11 window manager with Vulkan compositor."
7 HOMEPAGE
="https://github.com/jaelpark/chamferwm"
9 EGIT_REPO_URI
="https://github.com/jaelpark/chamferwm.git git://github.com/jaelpark/chamferwm.git"
11 inherit desktop git-r3 meson xdg
17 dev-libs/boost[python]
19 dev-util/vulkan-headers
20 media-libs/vulkan-loader
24 media-libs/vulkan-loader
25 dev-libs/boost[python]
29 sed -i "s/python3')/python-3.7')/g" meson.build
34 dobin
"${BUILD_DIR}/chamfer"
36 insinto
/usr
/share
/chamfer
/shaders
38 doins
"${BUILD_DIR}/default_fragment.spv"
39 doins
"${BUILD_DIR}/default_geometry.spv"
40 doins
"${BUILD_DIR}/default_vertex.spv"
41 doins
"${BUILD_DIR}/frame_fragment.spv"
42 doins
"${BUILD_DIR}/frame_geometry.spv"
43 doins
"${BUILD_DIR}/frame_vertex.spv"
45 domenu
"${S}/share/chamfer.desktop"