net-im/tencent-qq: bump version to 3.2.15_p241224
[gentoo-zh.git] / x11-wm / hypr / hypr-9999.ebuild
blob5946556a7fb2a3c77976b8f3fe1d19c075d8bf66
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake git-r3 toolchain-funcs
8 DESCRIPTION="A dynamic Linux tiling window manager for Xorg"
9 HOMEPAGE="https://github.com/hyprwm/Hypr"
10 EGIT_REPO_URI="https://github.com/hyprwm/Hypr.git"
12 LICENSE="BSD"
13 SLOT="0"
15 DEPEND="x11-libs/cairo
16 dev-build/ninja
17 x11-libs/libxcb
18 x11-base/xcb-proto
19 x11-libs/xcb-util
20 x11-libs/xcb-util-cursor
21 x11-libs/xcb-util-keysyms
22 x11-libs/xcb-util-wm
23 dev-cpp/gtkmm:3.0
24 gui-libs/gtk"
26 pkg_pretend() {
27 if ! tc-is-gcc; then
28 ewarn "Only GCC is officially supported as compiler"
29 ewarn "Proceed with your own caution"
33 src_install() {
34 dobin "${BUILD_DIR}/Hypr"
35 dodoc "${S}/example/hypr.conf"