app-vim/icomplete: drop (#879)
[gentoo-zh.git] / sys-kernel / xanmod-cacule-sources / xanmod-cacule-sources-5.12.ebuild
blob08866fe86c8a6d711c044180156bfd2ac49fcbe8
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI="6"
5 K_WANT_GENPATCHES="base extras"
6 K_GENPATCHES_VER="1"
7 K_SECURITY_UNSUPPORTED="1"
8 K_NOSETEXTRAVERSION="1"
9 ETYPE="sources"
10 IUSE="uksm cjktty"
11 DEPEND="
12 app-arch/cpio
13 dev-util/dwarves
14 dev-libs/libbpf
16 RDEPEND="!sys-kernel/xanmod-sources"
18 inherit kernel-2-src-prepare-overlay
19 detect_version
21 DESCRIPTION="Xanmod and UKSM sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
22 HOMEPAGE="https://xanmod.org/"
23 LICENSE+=" CDDL"
24 SRC_URI="
25 ${KERNEL_BASE_URI}/linux-5.12.tar.xz
26 https://github.com/HougeLangley/customkernel/releases/download/v5.12-patch/0001-patch-5.12.0-xanmod1-cacule.xz
27 ${GENPATCHES_URI}
30 src_unpack() {
31 UNIPATCH_LIST_DEFAULT=""
32 UNIPATCH_LIST="${DISTDIR}/0001-patch-5.12.0-xanmod1-cacule.xz"
33 kernel-2-src-prepare-overlay_src_unpack
36 KEYWORDS="~amd64"
38 src_prepare() {
40 if use uksm ; then
41 eapply "${FILESDIR}/v1-uksm.patch" || die
44 if use cjktty ; then
45 eapply "${FILESDIR}/v1-cjktty.patch" || die
48 kernel-2-src-prepare-overlay_src_prepare
52 pkg_postinst() {
53 elog "MICROCODES"
54 elog "Use xanmod-sources with microcodes"
55 elog "Read https://wiki.gentoo.org/wiki/Intel_microcode"