1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop unpacker xdg
8 DESCRIPTION="Typora will give you a seamless experience as both a reader and a writer."
9 HOMEPAGE="https://typora.io"
10 SRC_URI="https://web.archive.org/web/20211127121316if_/https://typora.io/linux/typora_${PV}_amd64.deb"
12 #TODO : update license
20 RDEPEND="x11-libs/libXScrnSaver"
25 rm -rf share/lintian || die
26 sed -i '/Change Log/d' share/applications/typora.desktop || die
31 local dir="/opt/${PN}"
36 fperms 0755 "${dir}/bin/typora"
37 fperms 4755 "${dir}/share/typora/chrome-sandbox"
38 dosym -r /opt/typora/bin/typora /usr/bin/typora
40 domenu share/applications/typora.desktop