net-misc/networkmanager-l2tp: treeclean
[gentoo-zh.git] / media-video / mpv-handler / mpv-handler-0.3.8.ebuild
blobb7da6b64d49f8134d162b77185d813435f1a6e71
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
6 EAPI=8
8 CRATES="
9         base64@0.22.0
10         bitflags@2.5.0
11         cfg-if@1.0.0
12         dirs-sys@0.4.1
13         dirs@5.0.1
14         equivalent@1.0.1
15         getrandom@0.2.14
16         hashbrown@0.14.3
17         indexmap@2.2.6
18         libc@0.2.153
19         libredox@0.1.3
20         memchr@2.7.2
21         option-ext@0.2.0
22         proc-macro2@1.0.81
23         quote@1.0.36
24         redox_users@0.4.5
25         serde@1.0.198
26         serde_derive@1.0.198
27         serde_spanned@0.6.5
28         syn@2.0.60
29         thiserror-impl@1.0.59
30         thiserror@1.0.59
31         toml@0.8.12
32         toml_datetime@0.6.5
33         toml_edit@0.22.12
34         unicode-ident@1.0.12
35         wasi@0.11.0+wasi-snapshot-preview1
36         windows-sys@0.48.0
37         windows-targets@0.48.5
38         windows_aarch64_gnullvm@0.48.5
39         windows_aarch64_msvc@0.48.5
40         windows_i686_gnu@0.48.5
41         windows_i686_msvc@0.48.5
42         windows_x86_64_gnu@0.48.5
43         windows_x86_64_gnullvm@0.48.5
44         windows_x86_64_msvc@0.48.5
45         winnow@0.6.6
48 inherit cargo desktop xdg
50 DESCRIPTION="Play website videos and songs with mpv & yt-dlp"
51 HOMEPAGE="https://github.com/akiirui/mpv-handler"
52 SRC_URI="
53         ${CARGO_CRATE_URIS}
54         https://github.com/akiirui/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
57 LICENSE="MIT"
58 # Dependent crate licenses
59 LICENSE+=" MIT MPL-2.0 Unicode-DFS-2016"
60 SLOT="0"
61 KEYWORDS="~amd64"
62 RESTRICT="strip"
64 RDEPEND="
65         media-video/mpv
68 src_install() {
69         dobin "target/release/mpv-handler"
70         dodoc "share/linux/config.toml"
71         domenu "share/linux/mpv-handler.desktop"
74 pkg_postinst() {
75         xdg_pkg_postinst
76         elog "install net-misc/youtube-dl (recommended) or net-misc/yt-dlp"
77         elog "to enable mpv to play video and music from the websites."