app-miac/ccal: add (#884)
[gentoo-zh.git] / dev-python / janus / janus-0.4.0.ebuild
blob8ef4fe34dc12e431f573977de8224790bacb6976
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
7 inherit distutils-r1
9 DESCRIPTION="Implementation of the asyncio (PEP 3156) event-loop with Qt"
10 HOMEPAGE="https://github.com/aio-libs/janus"
11 MY_P="${P/_alpha/a}"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
13 IUSE="test"
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64"
20 DEPEND="
21 dev-python/setuptools[${PYTHON_USEDEP}]
22 test? (
23 dev-python/pytest[${PYTHON_USEDEP}]
27 python_test() {
28 py.test -v || die "Tests fail with ${EPYTHON}"
31 python_install_all() {
32 distutils-r1_python_install_all