1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit cmake gnome2-utils xdg
8 if [[ "${PV}" == 9999 ]]; then
10 EGIT_REPO_URI
="https://github.com/fcitx/fcitx5-gtk.git"
13 S
="${WORKDIR}/${MY_PN}-${PV}"
14 SRC_URI
="https://github.com/fcitx/fcitx5-gtk/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
15 KEYWORDS
="~amd64 ~loong ~x86"
18 DESCRIPTION
="Gtk im module for fcitx5 and glib based dbus client library"
19 HOMEPAGE
="https://github.com/fcitx/fcitx5-gtk"
21 LICENSE
="BSD-1 GPL-2+ LGPL-2+ MIT"
23 IUSE
="gtk2 +gtk3 +gtk4 +introspection +snooper onlyplugin wayland"
24 REQUIRED_USE
="|| ( gtk2 gtk3 gtk4 )"
26 RDEPEND
="app-i18n/fcitx:5
27 gtk2? ( x11-libs/gtk+:2 )
28 gtk3? ( x11-libs/gtk+:3[wayland?] )
29 gtk4? ( gui-libs/gtk:4[wayland?] )
30 introspection? ( dev-libs/gobject-introspection )
31 kde-frameworks/extra-cmake-modules
46 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
47 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
48 -DCMAKE_BUILD_TYPE=Release
49 -DENABLE_GTK2_IM_MODULE=$
(usex gtk2
)
50 -DENABLE_GTK3_IM_MODULE=$
(usex gtk3
)
51 -DENABLE_GTK4_IM_MODULE=$
(usex gtk4
)
52 -DENABLE_SNOOPER=$
(usex snooper
)
53 -DENABLE_GIR=$
(usex introspection
)
54 -DBUILD_ONLY_PLUGIN=$
(usex onlyplugin
)
61 use gtk2
&& gnome2_query_immodules_gtk2
62 use gtk3
&& gnome2_query_immodules_gtk3
67 use gtk2
&& gnome2_query_immodules_gtk2
68 use gtk3
&& gnome2_query_immodules_gtk3